VisualRuby unable to load cairo.so

1.Fresh install: Glade3.6.7 & GTK with file: glade3-3.6.7-with-GTK+.exe
2.Ran glade3 - functions OK
3.Gem install visualruby - installation had no errors.
4 products installed:

  • Windows 7 Professional
  • ruby 1.9.3p545 (2014-02-24) [i386-mingw32]
  • gtk2 (2.2.0 x86-mingw32)
  • gtksourceview2 (2.2.0 x86-mingw32)
  • visualruby (1.0.16)
  1. In a CMD windows: vr it generates the following errors:

C:/RUBY193-327/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:126:in
require': cannot load such file -- cairo.so (LoadError) from C:/RUBY193-327/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:126:inrequire’
from
C:/RUBY193-327/lib/ruby/gems/1.9.1/gems/cairo-1.12.9-x86-mingw32/lib/cairo.rb:46:in
rescue in <top (required)>' from C:/RUBY193-327/lib/ruby/gems/1.9.1/gems/cairo-1.12.9-x86-mingw32/lib/cairo.rb:42:in<top (required)>’
from
C:/RUBY193-327/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:73:in
require' from C:/RUBY193-327/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:73:inrequire’
from
C:/RUBY193-327/lib/ruby/gems/1.9.1/gems/glib2-2.2.0-x86-mingw32/lib/glib2.rb:97:in
<top (required)>' from C:/RUBY193-327/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:73:inrequire’
from
C:/RUBY193-327/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:73:in
require' from C:/RUBY193-327/lib/ruby/gems/1.9.1/gems/gtk2-2.2.0-x86-mingw32/lib/gtk2/base.rb:12:in<top (required)>’
from
C:/RUBY193-327/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:73:in
require' from C:/RUBY193-327/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:73:inrequire’
from
C:/RUBY193-327/lib/ruby/gems/1.9.1/gems/gtk2-2.2.0-x86-mingw32/lib/gtk2.rb:11:in
<top (required)>' from C:/RUBY193-327/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:73:inrequire’
from
C:/RUBY193-327/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:73:in
require' from C:/RUBY193-327/lib/ruby/gems/1.9.1/gems/gtksourceview2-2.2.0-x86-mingw32/lib/gtksourceview2.rb:8:in<top (required)>’
from
C:/RUBY193-327/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:73:in
require' from C:/RUBY193-327/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:73:inrequire’
from
C:/RUBY193-327/lib/ruby/gems/1.9.1/gems/visualruby-1.0.16/vr:4:in <top (required)>' from C:/Ruby193-327/bin/vr:23:inload’
from C:/Ruby193-327/bin/vr:23:in `’

Hi,

In [email protected]
“[ruby-gnome2-devel-en] VisualRuby unable to load cairo.so” on Tue, 08
Apr 2014 05:35:44 +0200,
John S. [email protected] wrote:

4 products installed:

  • Windows 7 Professional
  • ruby 1.9.3p545 (2014-02-24) [i386-mingw32]

The latest cairo gem drops Ruby 1.9.3 + Windows
support. Could try with Ruby 2.0 or 2.1?

Thanks,

kou

I was successful in using ruby2.0 on windows 7 and also Windows 8,
with the fresh install of glade3-3.6.7-with-GTK+.exe and visualruby.

Many thanks for the timely response and a working solution.

PS if you upgrade from ruby 1.9 to ruby 2.0 be sure the the
file associations of .rb & .rbw have been updated.

John

We may wish to update the Visual Ruby web site as it currently indicates
the installation of ruby1.9.3 is required.

New to this forum and Visual Ruby, adny advice on getting the page
changed? Shall I log a defect against the page?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs