Virtual host in one ip address

I have a rackspace server running with nginx. I am a newbie to all the
server stuff. Let me explain the situation here:I have an IP address and
I have two virtual host on my machine.I don’t have a domain and I don’t
want to buy oneI want to map it so I can access the website as
xxx.xxx.xxx.xxx/v_host1 and xxx.xxx.xxx.xxx/v_host2How can I do this the
easy way? I am guessing I should change the nginx config of my site…
but not sure which one to change.

On Mar 4, 2011, at 7:22 , Alex H wrote:

I have a rackspace server running with nginx. I am a newbie to all the server
stuff. Let me explain the situation here:

I have an IP address and I have two virtual host on my machine.
I don’t have a domain and I don’t want to buy one
I want to map it so I can access the website as xxx.xxx.xxx.xxx/v_host1 and
xxx.xxx.xxx.xxx/v_host2
How can I do this the easy way? I am guessing I should change the nginx config
of my site… but not sure which one to change.

server {
location /v_host1/ {
root /path/to/v_host1;
}
location /v_host2/ {
root /path/to/v_host2;
}

Is this on the default of the nginx.conf?

From: [email protected]in.invalid
Date: Fri, 4 Mar 2011 09:01:33 +0300
To: [email protected]
Subject: Re: virtual host in one ip address

On Mar 4, 2011, at 7:22 , Alex H wrote:I have a rackspace server running
with nginx. I am a newbie to all the server stuff. Let me explain the
situation here:I have an IP address and I have two virtual host on my
machine.I don’t have a domain and I don’t want to buy oneI want to map
it so I can access the website as xxx.xxx.xxx.xxx/v_host1 and
xxx.xxx.xxx.xxx/v_host2How can I do this the easy way? I am guessing I
should change the nginx config of my site… but not sure which one to
change.server { location /v_host1/ { root /path/to/v_host1;
} location /v_host2/ { root /path/to/v_host2; }


Igor S.
http://sysoev.ru/en/

On Mar 4, 2011, at 9:10 , Alex H wrote:

Is this on the default of the nginx.conf?

I do not know what do you mean by default. The whole configuration is
like

http {
server {
location /v_host1/ {
}
location /v_host1/ {
}
}
}

That’s all.

What does "nginx -V " show ?

configure arguments: --conf-path=/etc/nginx/nginx.conf
–error-log-path=/var/log/nginx/error.log --pid-path=/var/run/nginx.pid
–lock-path=/var/lock/nginx.lock
–http-log-path=/var/log/nginx/access.log
–http-client-body-temp-path=/var/lib/nginx/body
–http-proxy-temp-path=/var/lib/nginx/proxy
–http-fastcgi-temp-path=/var/lib/nginx/fastcgi --with-debug
–with-http_stub_status_module --with-http_flv_module
–with-http_ssl_module --with-http_dav_module
–with-http_gzip_static_module --with-http_realip_module --with-mail
–with-mail_ssl_module --with-ipv6
–add-module=/build/buildd/nginx-0.7.65/modules/nginx-upstream-fair

From: removed_email_address[email protected]
Date: Fri, 4 Mar 2011 09:21:10 +0300
To: [email protected]
Subject: Re: virtual host in one ip address

What does "nginx -V " show ?

On Mar 4, 2011, at 9:17 , Alex H wrote:Where is this config file that I
need to edit?

From: [email protected]
Date: Fri, 4 Mar 2011 09:15:26 +0300
To: [email protected]
Subject: Re: virtual host in one ip address

On Mar 4, 2011, at 9:10 , Alex H wrote:Is this on the default of the
nginx.conf?

I do not know what do you mean by default. The whole configuration is
like
http { server { location /v_host1/ { } location
/v_host1/ { } }}
That’s all.
From: [email protected]
Date: Fri, 4 Mar 2011 09:01:33 +0300
To: [email protected]
Subject: Re: virtual host in one ip address

On Mar 4, 2011, at 7:22 , Alex H wrote:I have a rackspace server running
with nginx. I am a newbie to all the server stuff. Let me explain the
situation here:I have an IP address and I have two virtual host on my
machine.I don’t have a domain and I don’t want to buy oneI want to map
it so I can access the website as xxx.xxx.xxx.xxx/v_host1 and
xxx.xxx.xxx.xxx/v_host2How can I do this the easy way? I am guessing I
should change the nginx config of my site… but not sure which one to
change.server { location /v_host1/ { root /path/to/v_host1;
} location /v_host2/ { root /path/to/v_host2; }

Igor S.
http://sysoev.ru/en/

_______________________________________________ nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx_______________________________________________
nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx


Igor S.
http://sysoev.ru/en/

_______________________________________________ nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx_______________________________________________
nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx


Igor S.
http://sysoev.ru/en/

Where is this config file that I need to edit?

From: [email protected]
Date: Fri, 4 Mar 2011 09:15:26 +0300
To: [email protected]
Subject: Re: virtual host in one ip address

On Mar 4, 2011, at 9:10 , Alex H wrote:Is this on the default of the
nginx.conf?

I do not know what do you mean by default. The whole configuration is
like
http { server { location /v_host1/ { } location
/v_host1/ { } }}
That’s all.
From: [email protected]
Date: Fri, 4 Mar 2011 09:01:33 +0300
To: [email protected]
Subject: Re: virtual host in one ip address

On Mar 4, 2011, at 7:22 , Alex H wrote:I have a rackspace server running
with nginx. I am a newbie to all the server stuff. Let me explain the
situation here:I have an IP address and I have two virtual host on my
machine.I don’t have a domain and I don’t want to buy oneI want to map
it so I can access the website as xxx.xxx.xxx.xxx/v_host1 and
xxx.xxx.xxx.xxx/v_host2How can I do this the easy way? I am guessing I
should change the nginx config of my site… but not sure which one to
change.server { location /v_host1/ { root /path/to/v_host1;
} location /v_host2/ { root /path/to/v_host2; }

Igor S.
http://sysoev.ru/en/

_______________________________________________ nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx_______________________________________________
nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx


Igor S.
http://sysoev.ru/en/

-conf-path=/etc/nginx/nginx.conf

Hello,

what does noit work exactly. As I can see there may be a fastcgi_pass
missing to handle php (ex /phpmyadmin) and maybe index documents need to
be set.

Greets
Pascal

Am 04.03.2011 08:06, schrieb Alex H:

It just doesn’t work, here’s my .conf:
user www-data;worker_processes 4;
error_log /var/log/nginx/error.log;pid /var/run/nginx.pid;
events { worker_connections 1024; # multi_accept on;}
http { include /etc/nginx/mime.types;
server { location /phpmyadmin/ { root
/usr/share/phpmyadmin; }

    location /apiadmin/ {                root 

/var/www/api/src/frapi/admin/public; } }
access_log /var/log/nginx/access.log;
sendfile on; #tcp_nopush on;
#keepalive_timeout 0; keepalive_timeout 65; tcp_nodelay
on;
gzip on; gzip_disable "MSIE [1-6].(?!.SV1)";
include /etc/nginx/conf.d/
.conf; include
/etc/nginx/sites-enabled/*;}

mail {# # See sample authentication script at:#

http://wiki.nginx.org/NginxImapAuthenticateWithApachePhpScript## #
auth_http localhost/auth.php;# # pop3_capabilities “TOP” “USER”;#

imap_capabilities “IMAP4rev1” “UIDPLUS”;## server {#

listen localhost:110;# protocol pop3;# proxy
on;# }## server {# listen localhost:143;#
protocol imap;# proxy on;# }# }

and just for an FYI, in my sites-enabled I have:
server {
listen 80; server_name php.example.com;
access_log /var/log/nginx/localhost.access.log;
root /usr/share/phpmyadmin; index index.php;
location / { try_files $uri $uri/ @phpmyadmin; }
location @phpmyadmin { fastcgi_pass 127.0.0.1:9000;
fastcgi_param SCRIPT_FILENAME /usr/share/phpmyadmin/index.php;
include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_NAME
/index.php; }
# pass the PHP scripts to FastCGI server listening on
127.0.0.1:9000 # location ~ .php$ { fastcgi_pass
127.0.0.1:9000; fastcgi_index index.php; fastcgi_param
SCRIPT_FILENAME /usr/share/phpmyadmin$fastcgi_script_nam
e; include fastcgi_params; }}

this is the virtual host that I want to be accessed via
xxx.xxx.xxx.xxx/phpmyadmin

From: [email protected]
Date: Fri, 4 Mar 2011 09:35:10 +0300
To: [email protected]
Subject: Re: virtual host in one ip address

-conf-path=/etc/nginx/nginx.conf

On Mar 4, 2011, at 9:31 , Alex H wrote:configure arguments:
–conf-path=/etc/nginx/nginx.conf
–error-log-path=/var/log/nginx/error.log --pid-path=/var/run/nginx.pid
–lock-path=/var/lock/nginx.lock
–http-log-path=/var/log/nginx/access.log
–http-client-body-temp-path=/var/lib/nginx/body
–http-proxy-temp-path=/var/lib/nginx/proxy
–http-fastcgi-temp-path=/var/lib/nginx/fastcgi --with-debug
–with-http_stub_status_module --with-http_flv_module
–with-http_ssl_module --with-http_dav_module
–with-http_gzip_static_module --with-http_realip_module --with-mail
–with-mail_ssl_module --with-ipv6
–add-module=/build/buildd/nginx-0.7.65/modules/nginx-upstream-fair

From: [email protected]
Date: Fri, 4 Mar 2011 09:21:10 +0300
To: [email protected]
Subject: Re: virtual host in one ip address

What does "nginx -V " show ?

On Mar 4, 2011, at 9:17 , Alex H wrote:Where is this config file that I
need to edit?

From: [email protected]
Date: Fri, 4 Mar 2011 09:15:26 +0300
To: [email protected]
Subject: Re: virtual host in one ip address

On Mar 4, 2011, at 9:10 , Alex H wrote:Is this on the default of the
nginx.conf?

I do not know what do you mean by default. The whole configuration is
like
http { server { location /v_host1/ { } location
/v_host1/ { } }}
That’s all.
From: [email protected]
Date: Fri, 4 Mar 2011 09:01:33 +0300
To: [email protected]
Subject: Re: virtual host in one ip address

On Mar 4, 2011, at 7:22 , Alex H wrote:I have a rackspace server running
with nginx. I am a newbie to all the server stuff. Let me explain the
situation here:I have an IP address and I have two virtual host on my
machine.I don’t have a domain and I don’t want to buy oneI want to map
it so I can access the website as xxx.xxx.xxx.xxx/v_host1 and
xxx.xxx.xxx.xxx/v_host2How can I do this the easy way? I am guessing I
should change the nginx config of my site… but not sure which one to
change.server { location /v_host1/ { root /path/to/v_host1;
} location /v_host2/ { root /path/to/v_host2; }

Igor S.
http://sysoev.ru/en/

_______________________________________________ nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx_______________________________________________
nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx


Igor S.
http://sysoev.ru/en/

_______________________________________________ nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx_______________________________________________
nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx


Igor S.
http://sysoev.ru/en/

_______________________________________________ nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx_______________________________________________
nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx


Igor S.
http://sysoev.ru/en/

So I am confused as which one should I actually edit… there is a
nginx.conf and there is a default in the sites-enabled folder…

Date: Fri, 4 Mar 2011 09:34:00 +0100
From: [email protected]
To: [email protected]
Subject: Re: virtual host in one ip address

Hello,



what does noit work exactly. As I can see there may be a
fastcgi_pass missing to handle php (ex /phpmyadmin) and maybe index
documents need to be set.



Greets

Pascal



Am 04.03.2011 08:06, schrieb Alex H:


  It just
    doesn't work, here's my .conf:




    user
        www-data;
    worker_processes
         4;



    error_log
         /var/log/nginx/error.log;
    pid
             /var/run/nginx.pid;



    events
        {

         worker_connections  1024;
        #
        multi_accept on;
    }



    http
        {

         include       /etc/nginx/mime.types;




         server {

           location /phpmyadmin/ {

                   root  /usr/share/phpmyadmin;

           }







           location /apiadmin/ {

                   root  /var/www/api/src/frapi/admin/public;

           }
        }




         access_log  /var/log/nginx/access.log;




         sendfile        on;

         #tcp_nopush     on;




         #keepalive_timeout  0;

         keepalive_timeout  65;

         tcp_nodelay        on;




         gzip  on;

         gzip_disable "MSIE [1-6]\.(?!.*SV1)";




         include /etc/nginx/conf.d/*.conf;

         include /etc/nginx/sites-enabled/*;
    }



    #
        mail {
    #
        # See sample authentication script at:
    #
        #
        http://wiki.nginx.org/NginxImapAuthenticateWithApachePhpScript
    #
    #
        # auth_http localhost/auth.php;
    #
        # pop3_capabilities "TOP" "USER";
    #
        # imap_capabilities "IMAP4rev1" "UIDPLUS";
    #
    #
        server {
    #
            listen     localhost:110;
    #
            protocol   pop3;
    #
            proxy      on;
    #
        }
    #
    #
        server {
    #
            listen     localhost:143;
    #
            protocol   imap;
    #
            proxy      on;
    #
        }
    # }





    and just for an FYI, in my sites-enabled I have:




    server {



            listen   80;
            server_name php.example.com;



            access_log /var/log/nginx/localhost.access.log;



            root   /usr/share/phpmyadmin;
            index  index.php;



            location / {
            try_files $uri $uri/ @phpmyadmin;
            }



            location @phpmyadmin {
            fastcgi_pass 127.0.0.1:9000;
            fastcgi_param SCRIPT_FILENAME
      /usr/share/phpmyadmin/index.php;
            include /etc/nginx/fastcgi_params;
            fastcgi_param SCRIPT_NAME /index.php;
            }



            # pass the PHP scripts to FastCGI server listening
      on 127.0.0.1:9000
            #
            location ~ \.php$ {
            fastcgi_pass   127.0.0.1:9000;
            fastcgi_index  index.php;
            fastcgi_param  SCRIPT_FILENAME
       /usr/share/phpmyadmin$fastcgi_script_nam
                               e;
            include        fastcgi_params;
            }
    }






    this is the virtual host that I want to be accessed via
      xxx.xxx.xxx.xxx/phpmyadmin






    From:
      [email protected]

    Date: Fri,
      4 Mar 2011 09:35:10 +0300

    To:
      [email protected]

    Subject:
      Re: virtual host in one ip address








            -conf-path=/etc/nginx/nginx.conf









      On Mar 4, 2011, at 9:31 , Alex H wrote:



            configure arguments:
              --conf-path=/etc/nginx/nginx.conf
              --error-log-path=/var/log/nginx/error.log
              --pid-path=/var/run/nginx.pid
              --lock-path=/var/lock/nginx.lock
              --http-log-path=/var/log/nginx/access.log
              --http-client-body-temp-path=/var/lib/nginx/body
              --http-proxy-temp-path=/var/lib/nginx/proxy
              --http-fastcgi-temp-path=/var/lib/nginx/fastcgi
              --with-debug --with-http_stub_status_module
              --with-http_flv_module --with-http_ssl_module
              --with-http_dav_module --with-http_gzip_static_module
              --with-http_realip_module --with-mail
              --with-mail_ssl_module --with-ipv6
              --add-module=/build/buildd/nginx-0.7.65/modules/nginx-upstream-fair













            From: [email protected]

            Date: Fri, 4 Mar 2011 09:21:10 +0300

            To: [email protected]

            Subject: Re: virtual host in one ip address






            What does "nginx -V " show ?




                On Mar 4, 2011, at 9:17 , Alex H wrote:


                    Where is this
                      config file that I need to edit?











                      From: [email protected]

                      Date: Fri, 4 Mar 2011 09:15:26 +0300

                      To: [email protected]

                      Subject: Re: virtual host in one ip address




                        On Mar 4, 2011, at 9:10 , Alex H wrote:


                            Is this on the default of the
                              nginx.conf?






                        I do not know what do you mean by
                          default. The whole configuration is like



                        http {
                            server {
                                location
                            /v_host1/ {
                                }
                                location
                            /v_host1/ {
                                }
                            }
                        }



                        That's all.




                            From: [email protected]

                              Date: Fri, 4 Mar 2011 09:01:33 +0300

                              To: [email protected]

                              Subject: Re: virtual host in one ip
                              address




                                On Mar 4, 2011, at 7:22 , Alex
                                  H wrote:



                                          I have a rackspace server
                                          running with nginx. I am a
                                          newbie to all the server
                                          stuff. Let me explain the
                                          situation here:

                                          I have an
                                            IP address and I have
                                            two virtual host on my
                                            machine.
                                          I don't
                                            have a domain and I
                                            don't want to buy one
                                          I want to
                                            map it so I can access
                                            the website as
                                            xxx.xxx.xxx.xxx/v_host1
                                            and
                                            xxx.xxx.xxx.xxx/v_host2

                                        How
                                          can I do this the easy
                                          way? I am guessing I
                                          should change the nginx
                                          config of my site... but
                                          not sure which one to
                                          change.

                                server {
                                  location
                                  /v_host1/ {
                                      root
                                  /path/to/v_host1;
                                  }
                                  location
                                  /v_host2/ {
                                      root
                                  /path/to/v_host2;
                                  }






                                  --

                                  Igor S.

                                  http://sysoev.ru/en/




                              _______________________________________________
                              nginx mailing list [email protected] 

http://nginx.org/mailman/listinfo/nginx_______________________________________________

                              nginx mailing list

                              [email protected]

                              http://nginx.org/mailman/listinfo/nginx







                          --

                          Igor S.

                          http://sysoev.ru/en/




                      _______________________________________________
                      nginx mailing list [email protected] 

http://nginx.org/mailman/listinfo/nginx_______________________________________________

                      nginx mailing list

                      [email protected]

                      http://nginx.org/mailman/listinfo/nginx







                  --

                  Igor S.

                  http://sysoev.ru/en/





            _______________________________________________ nginx
            mailing list [email protected] 

http://nginx.org/mailman/listinfo/nginx_______________________________________________

            nginx mailing list

            [email protected]

            http://nginx.org/mailman/listinfo/nginx








        --

        Igor S.

        http://sysoev.ru/en/





    _______________________________________________

nginx
mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx


nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx

Alex;

Try reading the nginx wiki; It is very informative and can guide you
very well;

If you need someone to do it for you; perhaps you should consider paid
support.

check your server blocks;

you seem to have quite a few;

you only need one in your case.

So here’s what I have, all I can do at this point is navigate to
xxx.xxx.xxx.xxx but not to xxx.xxx.xxx.xxx/phpmyadmin:
user www-data;worker_processes 4;
error_log /var/log/nginx/error.log;pid /var/run/nginx.pid;
events { worker_connections 1024; # multi_accept on;}
http { include /etc/nginx/mime.types;
access_log /var/log/nginx/access.log;
sendfile on; #tcp_nopush on;
#keepalive_timeout 0; keepalive_timeout 65; tcp_nodelay
on;
gzip on; gzip_disable "MSIE [1-6].(?!.SV1)";
include /etc/nginx/conf.d/
.conf; include
/etc/nginx/sites-enabled/;
server { access_log
/var/log/nginx/admin.api.frapi/access.log;
location /api { if (-f $request_filename) { break;
}
rewrite ^/(.
)$ /index.php?$1 last; root
/var/www/api/src/frapi/admin/public; index index.php; }
location ~ .php$ { fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME
/var/www/api/src/frapi/admin/public/$fastcgi_script_name; include
fastcgi_params; } }
server {
access_log /var/log/nginx/localhost.access.log;
root /usr/share/phpmyadmin; index index.php;
location /phpmyadmin { try_files $uri $uri/
@phpmyadmin; }
location @phpmyadmin { fastcgi_pass 127.0.0.1:9000;
fastcgi_param SCRIPT_FILENAME /usr/share/phpmyadmin/index.php;
include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_NAME
/index.php; }
# pass the PHP scripts to FastCGI server listening on
127.0.0.1:9000 # location ~ .php$ { fastcgi_pass
127.0.0.1:9000; fastcgi_index index.php; fastcgi_param
SCRIPT_FILENAME /usr/share/phpmyadmin$fastcgi_script_name;
include fastcgi_params; } }
server { listen 80 default;
access_log /var/log/nginx/localhost.access.log;
location / { root /var/www/nginx-default;
index index.html index.htm; }
location /doc { root /usr/share;
autoindex on; allow 127.0.0.1; deny all;
}
location /images { root /usr/share;
autoindex on; }
#error_page 404 /404.html;
# redirect server error pages to the static page /50x.html

#error_page 500 502 503 504 /50x.html; #location =

/50x.html { # root /var/www/nginx-default; #}
# proxy the PHP scripts to Apache listening on 127.0.0.1:80

#location ~ .php$ { #proxy_pass

http://127.0.0.1; #}
# pass the PHP scripts to FastCGI server listening on
127.0.0.1:9000 # location ~ .php$ {
fastcgi_pass 127.0.0.1:9000; fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME
/var/www/nginx-default$fastcgi_script_name; include
fastcgi_params; }
# deny access to .htaccess files, if Apache’s document root

concurs with nginx’s one # location ~ /.ht {

deny all; }}

}

Date: Fri, 4 Mar 2011 08:44:23 -0500
From: [email protected]
To: [email protected]
Subject: Re: virtual host in one ip address

Alex;



Try reading the nginx wiki; It is very informative and can guide you
very well;



If you need someone to do it for you; perhaps you should consider
paid support.







On 3/4/11 8:38 AM, Alex H wrote:


  So I am confused as which one should I actually edit... there is a
  nginx.conf and there is a default in the sites-enabled folder..











  Date: Fri, 4 Mar 2011 09:34:00 +0100

  From: [email protected]

  To: [email protected]

  Subject: Re: virtual host in one ip address





  Hello,



  what does noit work exactly. As I can see there may be a
  fastcgi_pass missing to handle php (ex /phpmyadmin) and maybe
  index documents need to be set.



  Greets

  Pascal



  Am 04.03.2011 08:06, schrieb Alex H:

     It
      just doesn't work, here's my .conf:




      user

          www-data;
      worker_processes

           4;



      error_log

           /var/log/nginx/error.log;
      pid
                 /var/run/nginx.pid;



      events

          {


           worker_connections  1024;

           # multi_accept on;
      }



      http

          {


           include       /etc/nginx/mime.types;





           server {

               location /phpmyadmin/ {

                       root  /usr/share/phpmyadmin;

               }







               location /apiadmin/ {

                       root  /var/www/api/src/frapi/admin/public;

               }

           }





           access_log  /var/log/nginx/access.log;





           sendfile        on;


           #tcp_nopush     on;





           #keepalive_timeout  0;


           keepalive_timeout  65;


           tcp_nodelay        on;





           gzip  on;


           gzip_disable "MSIE [1-6]\.(?!.*SV1)";





           include /etc/nginx/conf.d/*.conf;


           include /etc/nginx/sites-enabled/*;
      }



      #
          mail {
      #
              # See sample authentication script at:
      #
              # 

http://wiki.nginx.org/NginxImapAuthenticateWithApachePhpScript
#
#
# auth_http localhost/auth.php;
#
# pop3_capabilities “TOP” “USER”;
#
# imap_capabilities “IMAP4rev1” “UIDPLUS”;
#
#
server {
#
listen localhost:110;
#
protocol pop3;
#
proxy on;
#
}
#
#
server {
#
listen localhost:143;
#
protocol imap;
#
proxy on;
#
}
#
}

      and just for an FYI, in my sites-enabled I have:




      server {



              listen   80;
              server_name php.example.com;



              access_log /var/log/nginx/localhost.access.log;



              root   /usr/share/phpmyadmin;
              index  index.php;



              location / {
              try_files $uri $uri/ @phpmyadmin;
              }



              location @phpmyadmin {
              fastcgi_pass 127.0.0.1:9000;
              fastcgi_param SCRIPT_FILENAME
        /usr/share/phpmyadmin/index.php;
              include /etc/nginx/fastcgi_params;
              fastcgi_param SCRIPT_NAME /index.php;
              }



              # pass the PHP scripts to FastCGI server
        listening on 127.0.0.1:9000
              #
              location ~ \.php$ {
              fastcgi_pass   127.0.0.1:9000;
              fastcgi_index  index.php;
              fastcgi_param  SCRIPT_FILENAME
         /usr/share/phpmyadmin$fastcgi_script_nam
                                   e;
              include        fastcgi_params;
              }
      }






      this is the virtual host that I want to be accessed via
        xxx.xxx.xxx.xxx/phpmyadmin






      From: [email protected]

      Date:
        Fri, 4 Mar 2011 09:35:10 +0300

      To: [email protected]

      Subject:

        Re: virtual host in one ip address






              -conf-path=/etc/nginx/nginx.conf









        On Mar 4, 2011, at 9:31 , Alex H wrote:



              configure arguments:
                --conf-path=/etc/nginx/nginx.conf
                --error-log-path=/var/log/nginx/error.log
                --pid-path=/var/run/nginx.pid
                --lock-path=/var/lock/nginx.lock
                --http-log-path=/var/log/nginx/access.log
                --http-client-body-temp-path=/var/lib/nginx/body
                --http-proxy-temp-path=/var/lib/nginx/proxy
                --http-fastcgi-temp-path=/var/lib/nginx/fastcgi
                --with-debug --with-http_stub_status_module
                --with-http_flv_module --with-http_ssl_module
                --with-http_dav_module
                --with-http_gzip_static_module
                --with-http_realip_module --with-mail
                --with-mail_ssl_module --with-ipv6
                --add-module=/build/buildd/nginx-0.7.65/modules/nginx-upstream-fair













              From: [email protected]

              Date: Fri, 4 Mar 2011 09:21:10 +0300

              To: [email protected]

              Subject: Re: virtual host in one ip address






              What does "nginx -V " show ?




                  On Mar 4, 2011, at 9:17 , Alex H wrote:


                      Where is this
                        config file that I need to edit?











                        From: [email protected]

                        Date: Fri, 4 Mar 2011 09:15:26 +0300

                        To: [email protected]

                        Subject: Re: virtual host in one ip address




                          On Mar 4, 2011, at 9:10 , Alex H
                            wrote:


                              Is this on the default of
                                the nginx.conf?






                          I do not know what do you mean by
                            default. The whole configuration is like



                          http {
                              server {
                                  location
                              /v_host1/ {
                                  }
                                  location
                              /v_host1/ {
                                  }
                              }
                          }



                          That's all.




                              From: [email protected]

                                Date: Fri, 4 Mar 2011 09:01:33 +0300

                                To: [email protected]

                                Subject: Re: virtual host in one ip
                                address




                                  On Mar 4, 2011, at 7:22 ,
                                    Alex H wrote:



                                            I have a rackspace
                                            server running with
                                            nginx. I am a newbie to
                                            all the server stuff.
                                            Let me explain the
                                            situation here:

                                            I have
                                              an IP address and I
                                              have two virtual host
                                              on my machine.
                                            I don't
                                              have a domain and I
                                              don't want to buy one
                                            I want
                                              to map it so I can
                                              access the website as
                                              xxx.xxx.xxx.xxx/v_host1

                                              and
                                              xxx.xxx.xxx.xxx/v_host2

                                          How can I
                                            do this the easy way? I
                                            am guessing I should
                                            change the nginx config
                                            of my site... but not
                                            sure which one to
                                            change.

                                  server {

                                     location /v_host1/ {

                                     root /path/to/v_host1;
                                    }

                                     location /v_host2/ {

                                     root /path/to/v_host2;
                                    }






                                    --

                                    Igor S.

                                    http://sysoev.ru/en/




                                _______________________________________________

                                nginx mailing list [email protected] 

http://nginx.org/mailman/listinfo/nginx_______________________________________________

                                nginx mailing list

                                [email protected]

                                http://nginx.org/mailman/listinfo/nginx







                            --

                            Igor S.

                            http://sysoev.ru/en/




                        _______________________________________________

                        nginx mailing list [email protected] 

http://nginx.org/mailman/listinfo/nginx_______________________________________________

                        nginx mailing list

                        [email protected]

                        http://nginx.org/mailman/listinfo/nginx







                    --

                    Igor S.

                    http://sysoev.ru/en/





              _______________________________________________ nginx
              mailing list [email protected] 

http://nginx.org/mailman/listinfo/nginx_______________________________________________

              nginx mailing list

              [email protected]

              http://nginx.org/mailman/listinfo/nginx







          --

          Igor S.

          http://sysoev.ru/en/




      _______________________________________________

nginx

        mailing list [email protected] 

http://nginx.org/mailman/listinfo/nginx


nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx

  _______________________________________________
  nginx mailing list
  [email protected]
  http://nginx.org/mailman/listinfo/nginx

nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx

Hello,

you should set all locations in one server block if just using the ip
since nginx will use the first (best?) block matchig (should be the one
listen 80 default; here) and just ignores the others.

Greets
Pascal

Am 04.03.2011 15:45, schrieb Alex H:

I think you should start from scratch using a very simple config.

Would not advise keeping your phpmyadmin directory public - change it to
something more obscure like phpmyadmin111 or something random. I’ve seen
too many webservers compromised because of a phpmyadmin installation
being far behind on an upgrade or you can restrict it to your IP.

Yea, sorry that was the old config file… Here’s the new one… which
still fails:
user www-data;worker_processes 4;
error_log /var/log/nginx/error.log;pid /var/run/nginx.pid;
events { worker_connections 1024; # multi_accept on;}
http { include /etc/nginx/mime.types;
access_log /var/log/nginx/access.log;
sendfile on; #tcp_nopush on;
#keepalive_timeout 0; keepalive_timeout 65; tcp_nodelay
on;
gzip on; gzip_disable "MSIE [1-6].(?!.SV1)";
include /etc/nginx/conf.d/
.conf; include
/etc/nginx/sites-enabled/;
server { listen 80 default;
access_log /var/log/nginx/localhost.access.log;
location / { root /var/www/nginx-default;
index index.html index.htm; }
location /api { if (-f $request_filename) {
break; }
rewrite ^/(.
)$ /index.php?$1 last;
root /var/www/api/src/frapi/admin/public; index
index.php; }
location /phpmyadmin { root
/usr/share/phpmyadmin; index index.php;
fastcgi_pass 127.0.0.1:9000;
fastcgi_param SCRIPT_FILENAME /usr/share/phpmyadmin/index.php;
include /etc/nginx/fastcgi_params; fastcgi_param
SCRIPT_NAME /index.php; }
location /doc { root /usr/share;
autoindex on; allow 127.0.0.1; deny all;
}
location /images { root /usr/share;
autoindex on; }
#error_page 404 /404.html;
# redirect server error pages to the static page /50x.html

#error_page 500 502 503 504 /50x.html; #location =

/50x.html { # root /var/www/nginx-default; #}
# proxy the PHP scripts to Apache listening on 127.0.0.1:80

#location ~ .php$ { #proxy_pass

http://127.0.0.1; #}
# pass the PHP scripts to FastCGI server listening on
127.0.0.1:9000 # location ~ .php$ {
fastcgi_pass 127.0.0.1:9000; fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME
/var/www/nginx-default$fastcgi_script_name; include
fastcgi_params; }
# deny access to .htaccess files, if Apache’s document root

concurs with nginx’s one # location ~ /.ht {

deny all; }}

}

Date: Fri, 4 Mar 2011 09:53:06 -0500
From: [email protected]
To: [email protected]
Subject: Re: virtual host in one ip address

Message body


check your server blocks;



you seem to have quite a few;



you only need one in your case.







On 3/4/11 9:45 AM, Alex H wrote:


  So here's
    what I have, all I can do at this point is navigate to
    xxx.xxx.xxx.xxx but not to xxx.xxx.xxx.xxx/phpmyadmin:




    user
        www-data;
    worker_processes
         4;



    error_log
         /var/log/nginx/error.log;
    pid
             /var/run/nginx.pid;



    events
        {

         worker_connections  1024;
        #
        multi_accept on;
    }



    http
        {

         include       /etc/nginx/mime.types;




         access_log  /var/log/nginx/access.log;




         sendfile        on;

         #tcp_nopush     on;




         #keepalive_timeout  0;

         keepalive_timeout  65;

         tcp_nodelay        on;




         gzip  on;

         gzip_disable "MSIE [1-6]\.(?!.*SV1)";




         include /etc/nginx/conf.d/*.conf;

         include /etc/nginx/sites-enabled/*;




         server {

           access_log  /var/log/nginx/admin.api.frapi/access.log;




         location /api {

           if (-f $request_filename) {

               break;

           }




           rewrite  ^/(.*)$  /index.php?$1  last;

           root   /var/www/api/src/frapi/admin/public;

           index  index.php;
        }




         location ~ \.php$ {

           fastcgi_pass   127.0.0.1:9000;

           fastcgi_index  index.php;

           fastcgi_param  SCRIPT_FILENAME
         /var/www/api/src/frapi/admin/public/$fastcgi_script_name;

           include fastcgi_params;

        }
        }




         server {




           access_log /var/log/nginx/localhost.access.log;




           root   /usr/share/phpmyadmin;

           index  index.php;




           location /phpmyadmin {

                   try_files $uri $uri/ @phpmyadmin;

           }




           location @phpmyadmin {

           fastcgi_pass 127.0.0.1:9000;

           fastcgi_param SCRIPT_FILENAME
        /usr/share/phpmyadmin/index.php;

           include /etc/nginx/fastcgi_params;

           fastcgi_param SCRIPT_NAME /index.php;

           }




           # pass the PHP scripts to FastCGI server listening on
        127.0.0.1:9000

           #

           location ~ \.php$ {

           fastcgi_pass   127.0.0.1:9000;

           fastcgi_index  index.php;

           fastcgi_param  SCRIPT_FILENAME
         /usr/share/phpmyadmin$fastcgi_script_name;

           include        fastcgi_params;

           }

        }




         server {

           listen   80 default;




           access_log  /var/log/nginx/localhost.access.log;




           location / {

                   root   /var/www/nginx-default;

                   index  index.html index.htm;

           }




           location /doc {

                   root   /usr/share;

                   autoindex on;

                   allow 127.0.0.1;

                   deny all;

           }




           location /images {

                   root   /usr/share;

                   autoindex on;

           }




           #error_page  404  /404.html;




           # redirect server error pages to the static page
        /50x.html

           #

           #error_page   500 502 503 504  /50x.html;

           #location = /50x.html {

           #       root   /var/www/nginx-default;

           #}




           # proxy the PHP scripts to Apache listening on
        127.0.0.1:80

           #

           #location ~ \.php$ {

                   #proxy_pass   http://127.0.0.1;

           #}




           # pass the PHP scripts to FastCGI server listening on
        127.0.0.1:9000

           #

           location ~ \.php$ {

                   fastcgi_pass   127.0.0.1:9000;

                   fastcgi_index  index.php;

                   fastcgi_param  SCRIPT_FILENAME
         /var/www/nginx-default$fastcgi_script_name;

                   include fastcgi_params;

           }




           # deny access to .htaccess files, if Apache's document
        root

           # concurs with nginx's one

           #

           location ~ /\.ht {

                   deny  all;

           }
    }






    }













    Date:
      Fri, 4 Mar 2011 08:44:23 -0500

    From:
      [email protected]

    To:
      [email protected]

    Subject:
      Re: virtual host in one ip address





     Alex;



     Try
      reading the nginx wiki; It is very informative and can guide
      you very well;



     If you
      need someone to do it for you; perhaps you should consider
      paid support.







     On 3/4/11
      8:38 AM, Alex H wrote:

       So I am confused as which one should I actually edit... there
      is a nginx.conf and there is a default in the sites-enabled
      folder..











      Date: Fri, 4 Mar 2011 09:34:00 +0100

      From: [email protected]

      To: [email protected]

      Subject: Re: virtual host in one ip address



      Hello,



      what does noit work exactly. As I can see there may be a
      fastcgi_pass missing to handle php (ex /phpmyadmin) and maybe
      index documents need to be set.



      Greets

      Pascal



      Am 04.03.2011 08:06, schrieb Alex H:

         It
          just doesn't work, here's my .conf:




          user www-data;
          worker_processes  4;



          error_log  /var/log/nginx/error.log;
          pid        /var/run/nginx.pid;



          events {
              worker_connections  1024;
              # multi_accept on;
          }



          http {
              include       /etc/nginx/mime.types;



              server {
                  location /phpmyadmin/ {
                          root  /usr/share/phpmyadmin;
                  }






                  location /apiadmin/ {
                          root
               /var/www/api/src/frapi/admin/public;
                  }
              }



              access_log  /var/log/nginx/access.log;



              sendfile        on;
              #tcp_nopush     on;



              #keepalive_timeout  0;
              keepalive_timeout  65;
              tcp_nodelay        on;



              gzip  on;
              gzip_disable "MSIE [1-6]\.(?!.*SV1)";



              include /etc/nginx/conf.d/*.conf;
              include /etc/nginx/sites-enabled/*;
          }



          # mail {
          #     # See sample authentication script at:
          #     # 

http://wiki.nginx.org/NginxImapAuthenticateWithApachePhpScript
#
# # auth_http localhost/auth.php;
# # pop3_capabilities “TOP” “USER”;
# # imap_capabilities “IMAP4rev1”
“UIDPLUS”;
#
# server {
# listen localhost:110;
# protocol pop3;
# proxy on;
# }
#
# server {
# listen localhost:143;
# protocol imap;
# proxy on;
# }
# }

          and just for an FYI, in my sites-enabled I have:




          server {



                  listen   80;
                  server_name php.example.com;



                  access_log
            /var/log/nginx/localhost.access.log;



                  root   /usr/share/phpmyadmin;
                  index  index.php;



                  location / {
                  try_files $uri $uri/ @phpmyadmin;
                  }



                  location @phpmyadmin {
                  fastcgi_pass 127.0.0.1:9000;
                  fastcgi_param SCRIPT_FILENAME
            /usr/share/phpmyadmin/index.php;
                  include /etc/nginx/fastcgi_params;
                  fastcgi_param SCRIPT_NAME /index.php;
                  }



                  # pass the PHP scripts to FastCGI server
            listening on 127.0.0.1:9000
                  #
                  location ~ \.php$ {
                  fastcgi_pass   127.0.0.1:9000;
                  fastcgi_index  index.php;
                  fastcgi_param  SCRIPT_FILENAME
             /usr/share/phpmyadmin$fastcgi_script_nam
                                           e;
                  include        fastcgi_params;
                  }
          }






          this is the virtual host that I want to be accessed
            via xxx.xxx.xxx.xxx/phpmyadmin






          From: [email protected]

          Date:

            Fri, 4 Mar 2011 09:35:10 +0300

          To:
            [email protected]

          Subject:


            Re: virtual host in one ip address






                  -conf-path=/etc/nginx/nginx.conf









            On Mar 4, 2011, at 9:31 , Alex H wrote:



                  configure arguments:
                    --conf-path=/etc/nginx/nginx.conf
                    --error-log-path=/var/log/nginx/error.log
                    --pid-path=/var/run/nginx.pid
                    --lock-path=/var/lock/nginx.lock
                    --http-log-path=/var/log/nginx/access.log
                    --http-client-body-temp-path=/var/lib/nginx/body
                    --http-proxy-temp-path=/var/lib/nginx/proxy
                    --http-fastcgi-temp-path=/var/lib/nginx/fastcgi
                    --with-debug --with-http_stub_status_module
                    --with-http_flv_module --with-http_ssl_module
                    --with-http_dav_module
                    --with-http_gzip_static_module
                    --with-http_realip_module --with-mail
                    --with-mail_ssl_module --with-ipv6
                    --add-module=/build/buildd/nginx-0.7.65/modules/nginx-upstream-fair













                  From: [email protected]

                  Date: Fri, 4 Mar 2011 09:21:10 +0300

                  To: [email protected]

                  Subject: Re: virtual host in one ip address






                  What does "nginx -V " show ?




                      On Mar 4, 2011, at 9:17 , Alex H wrote:


                          Where is this config file that
                            I need to edit?











                            From: [email protected]

                            Date: Fri, 4 Mar 2011 09:15:26 +0300

                            To: [email protected]

                            Subject: Re: virtual host in one ip
                            address




                              On Mar 4, 2011, at 9:10 , Alex H
                                wrote:


                                  Is this on
                                    the default of the nginx.conf?






                              I do not know what do you mean by
                                default. The whole configuration is
                                like



                              http {
                                  server {

                                   location /v_host1/ {
                                      }

                                   location /v_host1/ {
                                      }
                                  }
                              }



                              That's all.




                                  From: [email protected]

                                    Date: Fri, 4 Mar 2011 09:01:33
                                    +0300

                                    To: [email protected]

                                    Subject: Re: virtual host in one
                                    ip address




                                      On Mar 4, 2011, at 7:22 ,
                                        Alex H wrote:



                                                I have a rackspace
                                                server running with
                                                nginx. I am a newbie
                                                to all the server
                                                stuff. Let me
                                                explain the
                                                situation here:

                                                I
                                                  have an IP address
                                                  and I have two
                                                  virtual host on my
                                                  machine.
                                                I
                                                  don't have a
                                                  domain and I don't
                                                  want to buy one
                                                I
                                                  want to map it so
                                                  I can access the
                                                  website as
                                                  xxx.xxx.xxx.xxx/v_host1
                                                  and
                                                  xxx.xxx.xxx.xxx/v_host2

                                              How can
                                                I do this the easy
                                                way? I am guessing I
                                                should change the
                                                nginx config of my
                                                site... but not sure
                                                which one to change.

                                      server
                                        {

                                         location /v_host1/ {

                                         root /path/to/v_host1;
                                        }

                                         location /v_host2/ {

                                         root /path/to/v_host2;
                                        }






                                        --

                                        Igor S.

                                        http://sysoev.ru/en/




                                    _______________________________________________


                                    nginx mailing list 

[email protected]
http://nginx.org/mailman/listinfo/nginx_______________________________________________

                                    nginx mailing list

                                    [email protected]

                                    http://nginx.org/mailman/listinfo/nginx







                                --

                                Igor S.

                                http://sysoev.ru/en/




                            _______________________________________________


                            nginx mailing list [email protected] 

http://nginx.org/mailman/listinfo/nginx_______________________________________________

                            nginx mailing list

                            [email protected]

                            http://nginx.org/mailman/listinfo/nginx







                        --

                        Igor S.

                        http://sysoev.ru/en/





                  _______________________________________________
                  nginx mailing list [email protected] 

http://nginx.org/mailman/listinfo/nginx_______________________________________________

                  nginx mailing list

                  [email protected]

                  http://nginx.org/mailman/listinfo/nginx







              --

              Igor S.

              http://sysoev.ru/en/




          _______________________________________________

nginx

            mailing list [email protected] 

http://nginx.org/mailman/listinfo/nginx


nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx

      _______________________________________________ nginx mailing
      list [email protected] http://nginx.org/mailman/listinfo/nginx

nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx

    _______________________________________________

nginx
mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx


nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx

Why do you say that? Is the current one that I have very bad?I can see
that the logic is there, I am separating each vhost by location just as
you suggested…

Date: Fri, 4 Mar 2011 10:05:07 -0500
From: [email protected]
To: [email protected]
Subject: Re: virtual host in one ip address

I think you should start from scratch using a very simple config.







On 3/4/11 10:01 AM, Alex H wrote:


  Yea, sorry
    that was the old config file.. Here's the new one... which still
    fails:




    user
        www-data;
    worker_processes
         4;



    error_log
         /var/log/nginx/error.log;
    pid
             /var/run/nginx.pid;



    events
        {

         worker_connections  1024;
        #
        multi_accept on;
    }



    http
        {

         include       /etc/nginx/mime.types;




         access_log  /var/log/nginx/access.log;




         sendfile        on;

         #tcp_nopush     on;




         #keepalive_timeout  0;

         keepalive_timeout  65;

         tcp_nodelay        on;




         gzip  on;

         gzip_disable "MSIE [1-6]\.(?!.*SV1)";




         include /etc/nginx/conf.d/*.conf;

         include /etc/nginx/sites-enabled/*;




         server {

           listen   80 default;




           access_log  /var/log/nginx/localhost.access.log;




           location / {

                   root   /var/www/nginx-default;

                   index  index.html index.htm;

           }




           location /api {

                    if (-f $request_filename) {

                           break;

                    }




                   rewrite  ^/(.*)$  /index.php?$1  last;

                   root   /var/www/api/src/frapi/admin/public;

                   index  index.php;

           }




           location /phpmyadmin {

                    root   /usr/share/phpmyadmin;

                    index  index.php;




                    fastcgi_pass 127.0.0.1:9000;

                    fastcgi_param SCRIPT_FILENAME
        /usr/share/phpmyadmin/index.php;

                    include /etc/nginx/fastcgi_params;

                    fastcgi_param SCRIPT_NAME /index.php;

           }




           location /doc {

                   root   /usr/share;

                   autoindex on;

                   allow 127.0.0.1;

                   deny all;

           }




           location /images {

                   root   /usr/share;

                   autoindex on;

           }




           #error_page  404  /404.html;




           # redirect server error pages to the static page
        /50x.html

           #

           #error_page   500 502 503 504  /50x.html;

           #location = /50x.html {

           #       root   /var/www/nginx-default;

           #}




           # proxy the PHP scripts to Apache listening on
        127.0.0.1:80

           #

           #location ~ \.php$ {

                   #proxy_pass   http://127.0.0.1;

           #}




           # pass the PHP scripts to FastCGI server listening on
        127.0.0.1:9000

           #

           location ~ \.php$ {

                   fastcgi_pass   127.0.0.1:9000;

                   fastcgi_index  index.php;

                   fastcgi_param  SCRIPT_FILENAME
         /var/www/nginx-default$fastcgi_script_name;

                   include fastcgi_params;

           }




           # deny access to .htaccess files, if Apache's document
        root

           # concurs with nginx's one

           #

           location ~ /\.ht {

                   deny  all;

           }
    }






    }













    Date:
      Fri, 4 Mar 2011 09:53:06 -0500

    From:
      [email protected]

    To:
      [email protected]

    Subject:
      Re: virtual host in one ip address





    Message body
     check
      your server blocks;



     you seem
      to have quite a few;



     you only
      need one in your case.







     On 3/4/11
      9:45 AM, Alex H wrote:

       So
        here's what I have, all I can do at this point is navigate
        to xxx.xxx.xxx.xxx but not to xxx.xxx.xxx.xxx/phpmyadmin:




        user www-data;
        worker_processes  4;



        error_log  /var/log/nginx/error.log;
        pid        /var/run/nginx.pid;



        events {
            worker_connections  1024;
            # multi_accept on;
        }



        http {
            include       /etc/nginx/mime.types;



            access_log  /var/log/nginx/access.log;



            sendfile        on;
            #tcp_nopush     on;



            #keepalive_timeout  0;
            keepalive_timeout  65;
            tcp_nodelay        on;



            gzip  on;
            gzip_disable "MSIE [1-6]\.(?!.*SV1)";



            include /etc/nginx/conf.d/*.conf;
            include /etc/nginx/sites-enabled/*;



            server {
                access_log
             /var/log/nginx/admin.api.frapi/access.log;



            location /api {
                if (-f $request_filename) {
                    break;
                }



                rewrite  ^/(.*)$  /index.php?$1  last;
                root
            /var/www/api/src/frapi/admin/public;
                index  index.php;
            }



            location ~ \.php$ {
                fastcgi_pass   127.0.0.1:9000;
                fastcgi_index  index.php;
                fastcgi_param  SCRIPT_FILENAME
             /var/www/api/src/frapi/admin/public/$fastcgi_script_name;
                include fastcgi_params;
             }
            }



            server {



                access_log
            /var/log/nginx/localhost.access.log;



                root   /usr/share/phpmyadmin;
                index  index.php;



                location /phpmyadmin {
                        try_files $uri $uri/
            @phpmyadmin;
                }



                location @phpmyadmin {
                fastcgi_pass 127.0.0.1:9000;
                fastcgi_param SCRIPT_FILENAME
            /usr/share/phpmyadmin/index.php;
                include /etc/nginx/fastcgi_params;
                fastcgi_param SCRIPT_NAME /index.php;
                }



                # pass the PHP scripts to FastCGI
            server listening on 127.0.0.1:9000
                #
                location ~ \.php$ {
                fastcgi_pass   127.0.0.1:9000;
                fastcgi_index  index.php;
                fastcgi_param  SCRIPT_FILENAME
             /usr/share/phpmyadmin$fastcgi_script_name;
                include        fastcgi_params;
                }
             }



            server {
                listen   80 default;



                access_log
             /var/log/nginx/localhost.access.log;



                location / {
                        root   /var/www/nginx-default;
                        index  index.html index.htm;
                }



                location /doc {
                        root   /usr/share;
                        autoindex on;
                        allow 127.0.0.1;
                        deny all;
                }



                location /images {
                        root   /usr/share;
                        autoindex on;
                }



                #error_page  404  /404.html;



                # redirect server error pages to the
            static page /50x.html
                #
                #error_page   500 502 503 504
             /50x.html;
                #location = /50x.html {
                #       root   /var/www/nginx-default;
                #}



                # proxy the PHP scripts to Apache
            listening on 127.0.0.1:80
                #
                #location ~ \.php$ {
                        #proxy_pass   http://127.0.0.1;
                #}



                # pass the PHP scripts to FastCGI
            server listening on 127.0.0.1:9000
                #
                location ~ \.php$ {
                        fastcgi_pass   127.0.0.1:9000;
                        fastcgi_index  index.php;
                        fastcgi_param  SCRIPT_FILENAME
             /var/www/nginx-default$fastcgi_script_name;
                        include fastcgi_params;
                }



                # deny access to .htaccess files, if
            Apache's document root
                # concurs with nginx's one
                #
                location ~ /\.ht {
                        deny  all;
                }
        }






        }













        Date: Fri, 4 Mar 2011 08:44:23
          -0500

        From:

          [email protected]

        To:
          [email protected]

        Subject:

          Re: virtual host in one ip address




          Alex;




          Try reading the nginx wiki; It is very informative and can
          guide you very well;



         If
          you need someone to do it for you; perhaps you should
          consider paid support.







         On
          3/4/11 8:38 AM, Alex H wrote:

           So I am confused as which one should I actually edit... 

there
is a nginx.conf and there is a default in the
sites-enabled folder…

          Date: Fri, 4 Mar 2011 09:34:00
          +0100

          From: [email protected]

          To: [email protected]

          Subject: Re: virtual host in one ip address



          Hello,



          what does noit work exactly. As I can see there may be a
          fastcgi_pass missing to handle php (ex /phpmyadmin) and
          maybe index documents need to be set.



          Greets

          Pascal



          Am 04.03.2011 08:06, schrieb Alex H:

             It
              just doesn't work, here's my .conf:




              user www-data;
              worker_processes  4;



              error_log  /var/log/nginx/error.log;
              pid        /var/run/nginx.pid;



              events {
                  worker_connections  1024;
                  # multi_accept on;
              }



              http {
                  include       /etc/nginx/mime.types;



                  server {
                      location /phpmyadmin/ {
                              root
                   /usr/share/phpmyadmin;
                      }






                      location /apiadmin/ {
                              root
                   /var/www/api/src/frapi/admin/public;
                      }
                  }



                  access_log
                   /var/log/nginx/access.log;



                  sendfile        on;
                  #tcp_nopush     on;



                  #keepalive_timeout  0;
                  keepalive_timeout  65;
                  tcp_nodelay        on;



                  gzip  on;
                  gzip_disable "MSIE [1-6]\.(?!.*SV1)";



                  include /etc/nginx/conf.d/*.conf;
                  include /etc/nginx/sites-enabled/*;
              }



              # mail {
              #     # See sample authentication script
                  at:
              #     # 

http://wiki.nginx.org/NginxImapAuthenticateWithApachePhpScript
#
# # auth_http localhost/auth.php;
# # pop3_capabilities “TOP” “USER”;
# # imap_capabilities “IMAP4rev1”
“UIDPLUS”;
#
# server {
# listen localhost:110;
# protocol pop3;
# proxy on;
# }
#
# server {
# listen localhost:143;
# protocol imap;
# proxy on;
# }
# }

              and just for an FYI, in my sites-enabled I have:




              server {



                      listen   80;
                      server_name php.example.com;



                      access_log
                /var/log/nginx/localhost.access.log;



                      root   /usr/share/phpmyadmin;
                      index  index.php;



                      location / {
                      try_files $uri $uri/ @phpmyadmin;
                      }



                      location @phpmyadmin {
                      fastcgi_pass 127.0.0.1:9000;
                      fastcgi_param SCRIPT_FILENAME
                /usr/share/phpmyadmin/index.php;
                      include /etc/nginx/fastcgi_params;
                      fastcgi_param SCRIPT_NAME /index.php;
                      }



                      # pass the PHP scripts to FastCGI server
                listening on 127.0.0.1:9000
                      #
                      location ~ \.php$ {
                      fastcgi_pass   127.0.0.1:9000;
                      fastcgi_index  index.php;
                      fastcgi_param  SCRIPT_FILENAME
                 /usr/share/phpmyadmin$fastcgi_script_nam
                                                   e;
                      include        fastcgi_params;
                      }
              }






              this is the virtual host that I want to be
                accessed via xxx.xxx.xxx.xxx/phpmyadmin






              From: [email protected]

              Date: Fri, 4 Mar 2011 09:35:10 +0300

              To: [email protected]

              Subject: Re: virtual host in one ip address






                      -conf-path=/etc/nginx/nginx.conf









                On Mar 4, 2011, at 9:31 , Alex H wrote:



                      configure arguments:
                        --conf-path=/etc/nginx/nginx.conf
                        --error-log-path=/var/log/nginx/error.log
                        --pid-path=/var/run/nginx.pid
                        --lock-path=/var/lock/nginx.lock
                        --http-log-path=/var/log/nginx/access.log
                        --http-client-body-temp-path=/var/lib/nginx/body
                        --http-proxy-temp-path=/var/lib/nginx/proxy
                        --http-fastcgi-temp-path=/var/lib/nginx/fastcgi

                        --with-debug --with-http_stub_status_module
                        --with-http_flv_module
                        --with-http_ssl_module
                        --with-http_dav_module
                        --with-http_gzip_static_module
                        --with-http_realip_module --with-mail
                        --with-mail_ssl_module --with-ipv6
                        --add-module=/build/buildd/nginx-0.7.65/modules/nginx-upstream-fair













                      From: [email protected]

                      Date: Fri, 4 Mar 2011 09:21:10 +0300

                      To: [email protected]

                      Subject: Re: virtual host in one ip address






                      What does "nginx -V " show ?




                          On Mar 4, 2011, at 9:17 , Alex H
                            wrote:


                              Where is this config file
                                that I need to edit?











                                From: [email protected]

                                Date: Fri, 4 Mar 2011 09:15:26 +0300

                                To: [email protected]

                                Subject: Re: virtual host in one ip
                                address




                                  On Mar 4, 2011, at 9:10 ,
                                    Alex H wrote:


                                      Is
                                        this on the default of the
                                        nginx.conf?






                                  I do not know what do you
                                    mean by default. The whole
                                    configuration is like



                                  http {

                                       server {

                                       location /v_host1/ {
                                          }

                                       location /v_host1/ {
                                          }
                                      }
                                  }



                                  That's
                                      all.




                                      From: [email protected]

                                        Date: Fri, 4 Mar 2011
                                        09:01:33 +0300

                                        To: [email protected]

                                        Subject: Re: virtual host in
                                        one ip address




                                          On Mar 4, 2011, at
                                            7:22 , Alex H wrote:



                                                    I have a
                                                    rackspace server
                                                    running with
                                                    nginx. I am a
                                                    newbie to all
                                                    the server
                                                    stuff. Let me
                                                    explain the
                                                    situation here:

                                                    I
                                                      have an IP
                                                      address and I
                                                      have two
                                                      virtual host
                                                      on my machine.
                                                    I
                                                      don't have a
                                                      domain and I
                                                      don't want to
                                                      buy one
                                                    I
                                                      want to map it
                                                      so I can
                                                      access the
                                                      website as
                                                      xxx.xxx.xxx.xxx/v_host1
                                                      and
                                                      xxx.xxx.xxx.xxx/v_host2

                                                  How
                                                    can I do this
                                                    the easy way? I
                                                    am guessing I
                                                    should change
                                                    the nginx config
                                                    of my site...
                                                    but not sure
                                                    which one to
                                                    change.

                                          server

                                            {

                                             location /v_host1/ {

                                                 root
                                            /path/to/v_host1;

                                             }

                                             location /v_host2/ {

                                                 root
                                            /path/to/v_host2;

                                             }






                                            --

                                            Igor S.

                                            http://sysoev.ru/en/




                                        _______________________________________________



                                        nginx mailing list 

[email protected]
http://nginx.org/mailman/listinfo/nginx_______________________________________________

                                        nginx mailing list

                                        [email protected]

                                        http://nginx.org/mailman/listinfo/nginx







                                    --

                                    Igor S.

                                    http://sysoev.ru/en/




                                _______________________________________________



                                nginx mailing list [email protected] 

http://nginx.org/mailman/listinfo/nginx_______________________________________________

                                nginx mailing list

                                [email protected]

                                http://nginx.org/mailman/listinfo/nginx







                            --

                            Igor S.

                            http://sysoev.ru/en/





                      _______________________________________________

                      nginx mailing list [email protected] 

http://nginx.org/mailman/listinfo/nginx_______________________________________________

                      nginx mailing list

                      [email protected]

                      http://nginx.org/mailman/listinfo/nginx







                  --

                  Igor S.

                  http://sysoev.ru/en/





              _______________________________________________

nginx

                mailing list [email protected]
                http://nginx.org/mailman/listinfo/nginx

nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx

          _______________________________________________ nginx
          mailing list [email protected] 

http://nginx.org/mailman/listinfo/nginx


nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx

        _______________________________________________

nginx

          mailing list [email protected] 

http://nginx.org/mailman/listinfo/nginx


nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx

    _______________________________________________

nginx
mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx


nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs