Virtual host ayudaaaaaaaaa


#1

Auxilio he tratado de balancear la carga con apache y no he podido
lograr que se vea por : http://redmine:3001 y http:3002. Ayuda!!!
tengo esta configuracion en httpd-vhosts.conf

<VirtualHost *>

ServerName redmine

DocumentRoot /redmine-0.8

<Directory "/redmine-0.8/public">

FollowSymLinks

AllowOverride

Orden allow, deny

 allow from all

</ Directory>

<Proxy Balancer://mongrel_cluster>

Orden allow, deny

allow from all

BalancerMember http://127.0.0.1:3000

BalancerMember http://127.0.0.1:3001

BalancerMember http://127.0.0.1:3002

</ Proxy>

RewriteEngine On

RewriteCond% (DOCUMENT_ROOT) /% (REQUEST_FILENAME)!-F

RewriteRule ^/(.*)$ balanceador: / / redmine_cluster% (REQUEST_URI)

[P, QSA, L]

</ VirtualHost>

#2

2009/4/7 Kim K. removed_email_address@domain.invalid:

<Directory “/redmine-0.8/public”>

BalancerMember http://127.0.0.1:3002
</ VirtualHost>
¿Iniciaste los servicios en esos puertos?

script/server -p 3001
script/server -p 3002


#3

Si mira lo que me sale

script/server -p 3002
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.1.2 application starting on http://0.0.0.0:3002
=> Call with -d to detach
=> Ctrl-C to shutdown server
/usr/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/commands/servers/mongrel.rb:57:in
initialize': Permission denied - /home/jhony/Escritorio/redmine-0.8/log/development.log (Errno::EACCES) from /usr/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/commands/servers/mongrel.rb:57:inopen’
from
/usr/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/commands/servers/mongrel.rb:57
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:510:in
require' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:355:innew_constants_in’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:510:in
require' from /usr/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/commands/server.rb:39 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:ingem_original_require’
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require’
from script/server:3

que pasa??


#4

Me parece que por el mensaje que te sale en las primeras lineas tenes un
problema de permisos.

"/usr/lib/ruby/gems/1.8/gems/

rails-2.1.2/lib/commands/servers/mongrel.rb:57:in
`initialize’: Permission denied -

"

Fijate si podes correr esa linea con algun superusuario.-


  Agustin Viñao

www.agustinvinao.com
agustinvinao (Skype)

On Tue, Apr 7, 2009 at 4:43 PM, Kim K.


#5

Si no me equivoco tenes que revisar el database.yml para setear un
usuario
valido con la BD, creo que tenes seteado un usr: root sin pass que por
supuesto no es valido, confirma que tengas bien el usuario.


  Agustin Viñao

www.agustinvinao.com
agustinvinao (Skype)

On Tue, Apr 7, 2009 at 4:53 PM, Kim K.


#6

yo lo veo bien. que mas podria ser???

MySQL (default setup). Versions 4.1 and 5.0 are recommended.

Get the fast C bindings:

gem install mysql

(on OS X: gem install mysql – --include=/usr/local/lib)

And be sure to use new-style password hashing:

http://dev.mysql.com/doc/refman/5.0/en/old-client.html

production:
adapter: mysql
database: redmine
host: localhost
username: root
password: root
encoding: utf8
socket: /var/run/mysqld/mysqld.sock

development:
adapter: mysql
database: redmine_development
host: localhost
username: root
password: root
encoding: utf8

test:
adapter: mysql
database: redmine_test
host: localhost
username: root
password: root
encoding: utf8

test_pgsql:
adapter: postgresql
database: redmine_test
host: localhost
username: postgres
password: “postgres”

test_sqlite3:
adapter: sqlite3
dbfile: db/test.db

demo:
adapter: sqlite3
dbfile: db/demo.db


#7

YAAAAAAAAAA funciona que felicidad!!

GRACIAS!! MUCHAS GRACIAS!!


#8

seria muy bueno que explicaras brevemente como solucionaste el problema,
o
mas o menos como quedo la situacion que te llevo a solucionar el
problema.

On Tue, Apr 7, 2009 at 2:14 PM, Kim K.


#9

Muchas gracias no sabia que tocaba hacerlo por cada puerto :D. Pero
ahora me sale este error

Mysql::Error in WelcomeController#index

Access denied for user ‘root’@‘localhost’ (using password: NO)

RAILS_ROOT: /home/jhony/Escritorio/redmine-0.8

Request

Parameters:

None

Show session dump


flash: !map:ActionController::Flash::FlashHash {}

Response

Headers:

{“cookie”=>[],
“Cache-Control”=>“no-cache”}


#10

On Apr 8, 2009, at 12:34 AM, Rafael G. wrote:

Y para no tener que arrancar/parar todos los mongrels 1 por 1 te
recomiendo mongrel_cluster.

Si existe la posibilidad, utiliza Phusion Passenger. Mano de santo!


#11

Kim K. wrote:

YAAAAAAAAAA funciona que felicidad!!

GRACIAS!! MUCHAS GRACIAS!!

Y para no tener que arrancar/parar todos los mongrels 1 por 1 te
recomiendo mongrel_cluster.


#12

Antes configure el apache de xampp para la instalacion pero este
modifica /etc/httpd/extra/httpd-vhost.conf para el apache 2 es ese
mismo??? es que no lo encuentro. que diferencias debo hacer para el
apache2 a comparacion del xampp


#13

Pues la verdad hice lo que me dijiste, y ya el error de mysql no se que
era pero parecia que estaba corriendo el mysql del xampp pero no se.

Ahora estoy con el problemita de hacer los scripts para ejecutar el
mysql,mongrel y el apache. Si sabes de algo muchas gracias