Virtual Domains on 0.6

Hi,
I’m new to radiant, and I’m trying to migrate several sites over to a
radiant installation. In order to do this, I need to use the virtual
domains
plugin, which seems to be having some trouble with 0.6. I don’t quite
understand the difference between behaviors, plugins and extensions, but
extensions seem to be becoming the primary way of adding 3rd party
functionality in 0.6. I found this post:
http://www.nabble.com/one-radiant,-multiple-sites,-IIS-t3445856.html
which
mentions a 0.6 extension, but I’m having trouble locating it. As is,
putting
the plugin available from ThePlant.jp in the plugins folder makes rake
db:migration return an error about Undefined Constant Behavior, and the
patch says it can’t find some files. Can anyone point me in the right
direction?

Thanks.

-Daniel Fried

On Apr 12, 2007, at 5:03 PM, Dan Fried wrote:

ThePlant.jp in the plugins folder makes rake db:migration return an
error about Undefined Constant Behavior, and the patch says it
can’t find some files. Can anyone point me in the right direction?

The version from ThePlant is an old-style plugin. I’ve updated it to
a 0.6 extension. You can find it at http://silverinsanity.com/~benji/
radiant.

~~ Brian

Hi,

I have been working on the mental version and starting to develop
several extensions. I checked out the radiant svn version and use
svn:externals to checkout my extensions. Everything looks good until I
am ready to deploy.

The deployment machine is using gem version (instance mode) Radiant 0.6
RC2. When I run the rake test on my extension, my extension
test_helper.rb complained that it can not find radiant test and its test
helper files. Has anyone seen the same problem ? Can you run your own
extension test on instance method ?

Thanks in advance
Leon

Leon Yeh wrote:

Has anyone seen the same problem ? Can you run your own
extension test on instance method ?

Yes, I have seen that problem. This is when I switched to that mode
where you copy everything from the gems folder to your instance (I am
sorry, I really cannot grok the run-mode names) for extension
development.

I should not be too hard to fix the environment files to allow testing
in all modes. I am still too inexperieced to try.

Regards,
Erik.


Erik van Oosten

Thanks Erik,

Now I know someone else has the problem, I will see if I can fix this.

Leon Yeh
New Avenue Systems Inc.
Office: (626)254-1757 x880
[email protected]
Imagination Delivered. www.newavenue.net

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs