Vim two space indentation

Hi guys,

This has probably been done before but I’ve looked through 5000+ emails
and I’ve not seen a simple solution. I’d like to have two space
indentation for *.rb files or those whose first line begins with
!#/usr/bin/ruby. At the moment vim gives me eight spaces, (or is it a
tab?).

I have the following lines in ~./vimrc

set nocompatible
syntax on
filetype plugin indent on
filetype indent on " Enable filetype-specific indenting
filetype on " Enable filetype detection

I also have the following files;
/usr/share/vim/vim63/ftplugin/ruby.vim
/usr/share/vim/vim63/compiler/ruby.vim
/usr/share/vim/vim63/indent/ruby.vim
/usr/share/vim/vim63/syntax/ruby.vim

John M.
MSc (DIC)
07739 171 531

On Thu, Jan 05, 2006 at 09:23:23PM +0900, John M. wrote:
} Hi guys,
}
} This has probably been done before but I’ve looked through 5000+
emails and I’ve not seen a simple solution. I’d like to have two space
indentation for *.rb files or those whose first line begins with
!#/usr/bin/ruby. At the moment vim gives me eight spaces, (or is it a
tab?).
}
} I have the following lines in ~./vimrc
}
} set nocompatible
} syntax on
} filetype plugin indent on
} filetype indent on " Enable filetype-specific indenting
} filetype on " Enable filetype detection
}
} I also have the following files;
} /usr/share/vim/vim63/ftplugin/ruby.vim
} /usr/share/vim/vim63/compiler/ruby.vim
} /usr/share/vim/vim63/indent/ruby.vim
} /usr/share/vim/vim63/syntax/ruby.vim

I came to vim before the days of ftplugin. Actually, I came to vi first,
and already had filetype-specific configurations set up, so I sort of
ported that to vim when it came along. That said, the config lines you
want
are:

set ts=2 sw=2 expandtab

It looks to me like you want it in either the ftplugin or indent
directory,
but I’m not sure which. I believe the indent directory is intended for
automatic indentation configuration (equivalent to cindent), but again I
am
not sure.

} John M.
–Greg

On Thu, 05 Jan 2006 12:31:09 -0000, Gregory S.
[email protected] wrote:

}
} /usr/share/vim/vim63/syntax/ruby.vim
directory,
but I’m not sure which. I believe the indent directory is intended for
automatic indentation configuration (equivalent to cindent), but again I
am
not sure.

} John M.
–Greg

I just have it in ~/.vimrc, as follows:

set nocompatible
syntax on
filetype plugin indent on
set tabstop=2
set shiftwidth=2
set expandtab

Thanks!

I put the folowing line:-
set ts=2 sw=2 expandtab
into /usr/share/vim/vim63/indent/ruby.vim and it works

On Thu, 5 Jan 2006 21:31:09 +0900

Hi,

I use a setting like that in my .vimrc file.

if has(“autocmd”)

augroup ruby
au BufReadPre,FileReadPre set kp=ri sw=2 ts=2 expandtab
augroup END

endif

With some more settings for Python, Perl and so on. And I would also
suggest to active autoindent and smartindent. :slight_smile:

Best regards,
Oliver

John M. wrote:

Hi guys,

This has probably been done before but I’ve looked through 5000+ emails and I’ve not seen a simple solution. I’d like to have two space indentation for *.rb files or those whose first line begins with !#/usr/bin/ruby. At the moment vim gives me eight spaces, (or is it a tab?).
[…]

The best answer is to create a file ~/.vim/ftplugin/ruby.vim with the
following

set ts=2 sw=2 sts=2 et

Regards,
Gavin

Hi,

“Gavin S.” [email protected] writes:

John M. wrote:

Hi guys,

This has probably been done before but I’ve looked through 5000+ emails and I’ve not seen a simple solution. I’d like to have two space indentation for *.rb files or those whose first line begins with !#/usr/bin/ruby. At the moment vim gives me eight spaces, (or is it a tab?).
[…]

The best answer is to create a file ~/.vim/ftplugin/ruby.vim with the
following

set ts=2 sw=2 sts=2 et

In this case, it might be better to use setlocal instead of set.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs