Version issue with First App in Hartl Tutorial

Stepping through the Hartl Rails 3 Tutorial from the 2nd edition book
hot
off the presses. Modified the Gemfile exactly as specified in the
book,
immediately got version issues:

Could not find gem ‘jquery-rails (= 2.0.0) x86-mingw32’, etc., etc.

Tried removing the version spec from various gems, but it was like
peeling
an onion - other stuff would start failing.

Running Win 7 for Rails.

Any help appreciated. Thanks.

Have you checked the free online version of the book for the latest
updates?

I went and checked the jquery-rails gem, and it says this:

2.1.3 September 24, 2012
2.1.2 September 6, 2012
2.1.1 August 18, 2012
2.1.0 August 16, 2012
2.0.3 August 16, 2012
2.0.2 April 3, 2012
2.0.1 February 28, 2012
2.0.0 December 20, 2011 yanked

In other words, version 2.0.0 was so effed up they didn’t even bother to
patch it. So that is probably why you are having problems.

Also, in the future you might want to cite a chapter and page number to
give people a clue as to what you are referring to.

On 13 October 2012 15:47, Tim E. [email protected] wrote:

Stepping through the Hartl Rails 3 Tutorial from the 2nd edition book hot
off the presses. Modified the Gemfile exactly as specified in the book,
immediately got version issues:

Could not find gem ‘jquery-rails (= 2.0.0) x86-mingw32’, etc., etc.

Tried removing the version spec from various gems, but it was like peeling
an onion - other stuff would start failing.

Running Win 7 for Rails.

I can’t help with the problem I am afraid, but since no-one has
provided a solution I feel I should point out that RoR development on
Windows can be problematic and many believe that it is better to use
Linux (Ubuntu for example) or Mac. You have not said how you
installed Rails, I believe that on windows railsinstaller.org is
considered a good solution.

Colin

I am using linux mint maya. And unfortunately facing the same problem. I
dont think this is an issue of windows or linux. But is there any
problem using jquery-rails 2.1.0 or any latest one?

On 10 March 2013 10:37, Tajul A. [email protected] wrote:

Hi all

I faced the same problem. So any solution right now? Can I switch to
other version?

Which same problem? With windows as the OP or mint?

Colin

Hi all

I faced the same problem. So any solution right now? Can I switch to
other version?

On my Windows. The version maybe contain bugs or no longer supported. I
try to move the ‘2.0.0’ but still other problem occured with json 1.7.7.
Any solution guys or should us email to Harlt personally.

I don’t know why this works, but I found it on Stack Overflow and it
worked for me. (I’m going through Hartl’s second edition.)

Run this first (it installs the gem separately):

gem install jquery-rails

And then try bundle install again.

it would be easier if you provide a snapshot of your gemfile.
My suggestion is to install jquery- rails gem according to this link:
https://github.com/indirect/jquery-rails

On Saturday, October 13, 2012 10:47:44 AM UTC-4, Tim E. wrote:

Running Win 7 for Rails.

Any help appreciated. Thanks.

Something’s a little off. Your message indicates that version 2.0.0 of
jquery-rails is missing. The 2nd edition of the Rails Tutorial uses
version 2.0.2, not 2.0.0. If you have 2.0.2 in your gemfile, It is
possible that one of the other gems is requiring 2.0.0 as a dependency.

If that’s the case, I would force the install of version 2.0.0 as
follows:

gem install jquery-rails --version ‘2.0.0’

It is very important that you use the version of the gems specified in
the
book. In particular, if you do not use the same version of rspec and
capybara as the book does, you will have real problems. FYI, the full
source code of the application you will be building in the tutorial
(which
includes the gemfile) is available at:

github/railstutorial/sample_app_2nd_ed

I am running Windows 8 and I received the same error message as that
reported by Tim E…

I was also following the printed book. I have the second edition, and on
page 21 the book (twice, actually) specifies version ‘2.0.0’ for
jquery-rails. When I ran “bundle install” (after editing the Gemfile for
first_app) I received this error message:

“Could not find gem ‘jquery-rails (= 2.0.0) x86-mingw32’ in the gems
available on this machine.”

But when I changed the jquery-rails version to 2.0.2 everything worked
fine.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs