Version fu problem


#1

Hi,

I have a class that uses version_fu (Page class) the issue is that if
I run a clean migration it fails on the version_fu declaration in the
Page class, Its looking for the page_versions column that has not been
created yet.

Anyone seen this before?

Looks like if I do

version_fu rescue nil

The error does not show and my migration runs all the way to the
end… isn’t that just ugly?


#2

Freddy A. wrote:

I have a class that uses version_fu (Page class) the issue is that if
I run a clean migration it fails on the version_fu declaration in the
Page class, Its looking for the page_versions column that has not been
created yet.

For this reason you should use rake db:schema:load instead of
db:migrate.
Otherwise, you’ll have to come up with ugly tricks.


Roderick van Domburg
http://www.nedforce.com