VERBOSE and "warning: Insecure world writable dir..."

Hello,

I’ve just got very popular – as I guess from google hits – warning
about insecure dir when I run something like this
puts %x{bzip2 -9 #{s}}

where s is file to compress.

I found many ‘solutions’ by changing the access to directories to
satisfy ruby, I don’t want to do this but just turn this warning
off. I found the answer – setting $VERBOSE to nil works great,
however I guess it shuts down all warnings.

So how can I turn off this one and only type of warning? And I don’t
want to mess with my system settings, so please do not discuss this
subject.

Thanks in advance for help,
have a nice day
bye

On Sat, 4 Nov 2006, Maciej P. wrote:

off. I found the answer – setting $VERBOSE to nil works great,
however I guess it shuts down all warnings.

So how can I turn off this one and only type of warning? And I don’t
want to mess with my system settings, so please do not discuss this
subject.

Thanks in advance for help,
have a nice day

$VERBOSE = nil

or

ruby -W0 a.rb

-a

On Sat, 4 Nov 2006 23:49:51 +0900, [email protected] wrote:

I found the answer – setting $VERBOSE to nil works great

$VERBOSE = nil

Yes, indeed, I was curious how to set the variable to nil, gee…
Please, read my question – my problem is I want to turn off only
specific warnings, not all.

have a nice day
bye

Maciej P. wrote:

I’ve just got very popular – as I guess from google hits – warning
about insecure dir when I run something like this
puts %x{bzip2 -9 #{s}}
where s is file to compress.

I found many ‘solutions’ by changing the access to directories to
satisfy ruby, I don’t want to do this but just turn this warning
off. I found the answer – setting $VERBOSE to nil works great,
however I guess it shuts down all warnings.

There are also other answers, if you continue Googling. The first page
of google hits for that phrase includes both a patch to 1.8.5 as well
as several mentions of changing the $PATH.

On Sun, 5 Nov 2006, Maciej P. wrote:

On Sat, 4 Nov 2006 23:49:51 +0900, [email protected] wrote:

I found the answer – setting $VERBOSE to nil works great

$VERBOSE = nil

Yes, indeed, I was curious how to set the variable to nil, gee…
Please, read my question – my problem is I want to turn off only
specific warnings, not all.

google is your friend

http://groups-beta.google.com/group/comp.lang.ruby/browse_thread/thread/cddd8d3931ba6365/5c2b4ed2c385128d?lnk=gst&q=VERBOSE+world+writable+directory&rnum=1#5c2b4ed2c385128d

http://groups-beta.google.com/group/comp.lang.ruby/browse_thread/thread/3c64870ac4241bd7/11da27e099da1100?lnk=gst&q=VERBOSE+world+writable+directory&rnum=2#11da27e099da1100

included is a patch by eric hodel which does what you desire.

-a

[email protected] wrote:

quietly do
what_you_were_doing_before
end

Hmm. Is $VERBOSE thread-local?

David V.

On Sun, 5 Nov 2006, Maciej P. wrote:

have a nice day
then you have the answer

def quietly
v = $VERBOSE
$VERBOSE = nil
yield
ensure
$VERBOSE = v
end

quietly do
what_you_were_doing_before
end

it’s as good as it gets.

-a

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs