Vbseo rewrite


I have a wordpress site with vbulletin+vBSEO forum section under
“/forum/” directory and I’m trying to move this site from apache2 to
nginx 1.0.12.
Everything works good except the vBSEO rewrite rules.

The webserver is configured with a chain(1) of serveral components in
order to speed up the web requests.
I have “varnish” listening on port 80 that forwards the requests to
nginx on port 8069.
Nginx is provided with apc cache and uses php-fpm on port “9000” to
handle php requests.
The wordpress is also provided with W3TotalCache.
Tha server setup is based on ISPConfig

When I try to access the forum section I recive a “500 Internal Server
/var/log/ispconfig/httpd/www.domain.com/error.log says:

[error] 14702#0: *30 rewrite or internal redirection cycle while
processing “/forum/vbseo.php”, client:, server:
www.dominio.com, request: “GET /forum/ HTTP/1.1”, host:
www.dominio.com”, referrer: “Website Domain Names, Online Stores & Hosting | Domain.com

The “forum” section is linked from the main wordpress menu.
If I try to access directly the sections of the forum using the
drop-down menù in wordpress I’m able to see it but the URL rewrited is
not correct. The URL displayed is “Website Domain Names, Online Stores & Hosting | Domain.com
instead of “Website Domain Names, Online Stores & Hosting | Domain.com”.
However, this is a secondary problem.

/etc/nginx.conf is the default, I just added this lines of code for
Cloudflare part:

real_ip_header CF-Connecting-IP;

This(2) is my "/etc/nginx/sites-enabled/dominio.vhost:

As you can see the configuration file is subdivided in 4 sections:

  • general
  • vBulletin - VBSEO
  • wordpress
  • W3TotalCache

I tried to remove wordpress and W3TC part in order to exclude conflict
problems but I didn’t resolved the issue.
Anyway I tried it with other rewrite URL set.

The vBSEO rewrite rule set is the one suggested by vBSEO developers.

I’ve already opened a support ticket on vBSEO customer support section.
They says the code is correct and I have a conflict issue with wordpress
and other directives.
This what tey say:

Your nginx rules look ok but the issue is it looks like you have
conflicting url rewrite rules all around.
You should either hire an experienced nginx administrator to fix the
issue or remove your wordpress rules as they don’t look ok and we can’t
assist you on fixing third party script rules.

Your rules look ok. However you seem to have other issues. Again your
best bet is hiring someone experienced or reverting back to the web
server you are confident with.

If is necessary I can upload this other configuration files:

  • nginx.conf (entire)
  • apc.ini
  • a txt file with all the rewrite rule sets i tried.
  • php.ini
  • php-fpm.conf
  • default.vcl

Thank you in advance for your reply.

(1) all the requests comes from cloudflare - I set up all the
“set_real_ip” directives in nginx.conf

(2) I used “pastebin” service as a matter of order of this post.

Posted at Nginx Forum: