Value error

Hi
I have a problem with ofdm system.

Each time I run benchmark_ofdm_rx.py I get;

Traceback (most recent call last):
File “benchmark_ofdm_rx.py”, line 210, in
main()
File “benchmark_ofdm_rx.py”, line 199, in main
tb = my_top_block(rx_callback, options)
File “benchmark_ofdm_rx.py”, line 64, in init
self.rxpath = receive_path(callback, options)
File “/home/crespi/Desktop/Workspace_flo/receive_path.py”, line 52, in
init
blks2.ofdm_demod(options, callback=self._rx_callback)
File
“/usr/local/lib/python2.5/site-packages/gnuradio/blks2impl/ofdm.py”,
line
209, in init
self.ofdm_recv = ofdm_receiver(self._fft_length,
self._cp_length,self._occupied_tones, self._snr, preambles,options.log)
File
“/usr/local/lib/python2.5/site-packages/gnuradio/blks2impl/ofdm_receiver.py”,
line 107, in init
self.connect((self.ofdm_sync,1), (self.ofdm_frame_acq,1))
File
“/usr/local/lib/python2.5/site-packages/gnuradio/gr/hier_block2.py”,
line
70, in connect
self._connect(points[i-1], points[i])
File
“/usr/local/lib/python2.5/site-packages/gnuradio/gr/hier_block2.py”,
line
76, in _connect
dst_block.basic_block(), dst_port)
File
“/usr/local/lib/python2.5/site-packages/gnuradio/gr/gnuradio_swig_py_runtime.py”,
line 946, in connect
return _gnuradio_swig_py_runtime.gr_hier_block2_sptr_connect(*args)
ValueError: port number 1 exceeds max of 0

I use realese number 7324 and kubuntu 7.04

Do you have some idea of which the problem is???

Thanks a lot of

On 3/18/08, Crespi F. [email protected] wrote:

I have a problem with ofdm system.

I use realese number 7324 and kubuntu 7.04

Please update to the current trunk release. I believe what you are
seeing is fixed in r7802, but not entirely certain.


Johnathan C.
Corgan Enterprises LLC
http://corganenterprises.com/

On Tue, Mar 18, 2008 at 05:54:37PM +0100, Crespi F. wrote:

File “benchmark_ofdm_rx.py”, line 64, in init
line 107, in init
return _gnuradio_swig_py_runtime.gr_hier_block2_sptr_connect(*args)
ValueError: port number 1 exceeds max of 0

I use realese number 7324 and kubuntu 7.04

Do you have some idea of which the problem is???

Thanks a lot of

Can you try updating to the current trunk version and see if the
problem still persists?

Eric

Hi,
I made the updating of the program, but the problem persists.
PN sync doesn’t have problem.
You have an idea of thing I could do for resolving the problem.
Thank you a lot for your help.

Scrive Eric B. [email protected]:

tb = my_top_block(rx_callback, options)

File
76, in _connect
dst_block.basic_block(), dst_port)
File

“/usr/local/lib/python2.5/site-packages/gnuradio/gr/gnuradio_swig_py_runtime.py”,

Crespi F. wrote:

Hi,
I made the updating of the program, but the problem persists.
PN sync doesn’t have problem.
You have an idea of thing I could do for resolving the problem.
Thank you a lot for your help.

Are you saying the system works when you use the PN synchronization
block ofdm_sync_pn.py but not if you switch out the PN version for, say,
the ML version (ofdm_sync_ml.py)? If that’s the problem, then there is
no current (easy) solution. In order to fix some operational problems, I
had to make changes to the way the systems interconnect and broke the
other synchronization methods in the process. This isn’t really a
problem since the other sync methods don’t work properly, anyway. I have
plans to fix this, but I can’t say when.

Tom

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs