Validates acceptance of question


#1

I have a terms of service agreement attached to a checkbox. It seems
to work ok and I see

“agreement”=>“0” when the box is not checked in the development log

and

“agreement”=>“1” when the box is checked in the log.

But in the model I this validation:

validates_acceptance_of :agreement,
:message => “Please accept the terms to
proceed”

So when the form is actually filled out, no matter whether the box is
checked or not I get:

1 error prohibited this agent from being saved

There were problems with the following fields:

-Agreement, Please accept the terms to proceed

So what am I missing to get this to work?


#2

There were problems with the following fields:

-Agreement, Please accept the terms to proceed

So what am I missing to get this to work?

is :agreement a field in your database? if so the docs say…

:accept - Specifies value that is considered accepted. The default
value is a string “1”, which makes it easy to relate to an HTML
checkbox. This should be set to true if you are validating a database
column, since the attribute is typecast from “1” to true before
validation.


#3

Yes, :agreement is a field in my database. Should I remove it?
In any case I did set the :accept => “true”, but it didn’t change
anything. I get the same error when I submit the form whether or not
the box is checked.
The html shows:

    Am I reading this right that after the checkbox value is set to “1”
    that then there is a hidden value that is setting it to “0”? Is this
    supposed to be this way?


#4

On Dec 2, 2008, at 10:05 PM, removed_email_address@domain.invalid wrote:

Yes, :agreement is a field in my database. Should I remove it?
In any case I did set the :accept => “true”, but it didn’t change
anything. I get the same error when I submit the form whether or not
the box is checked.

Set :accept => true (no quotes). That’s how I read the docs… if
it’s a database column, you need that.


#5

Thanks for your help. That was it. Remove the quotes and it works.