uWSGI + Moin (subdir) + Nginx

Hi,

I followed the example in:

http://projects.unbit.it/uwsgi/wiki/Example#MoinMoinonlinenow

However when I type domain/wiki I get a message that the page does not
exist yet… which already tells me something is wrong, and also all my
URL’s are point to ‘/’ not ‘/wiki’

I can’t seem to figure out why this happens… I tough using:

uwsgi_param SCRIPT_NAME /wiki;
uwsgi_modifier1 30;

Would do the trick… but It doesn’t…

Please note that I’m using moin-1.9.4, py27-uwsgi-1.2.4

As for nginx:

nginx version: nginx/1.3.14
built by gcc 4.5.3 (NetBSD nb2 20110806)
TLS SNI support enabled
configure arguments: --user=nginx --group=nginx
–with-openssl=/home/miguelc/sources/openssl-1.0.1e
–with-ld-opt=’-L/usr/pkg/lib -Wl,-R/usr/pkg/lib’ --prefix=/usr/pkg
–sbin-path=/usr/pkg/sbin --conf-path=/usr/pkg/etc/nginx/nginx.conf
–pid-path=/var/run/nginx.pid --lock-path=/var/db/nginx/nginx.lock
–error-log-path=/var/log/nginx/error.log
–http-log-path=/var/log/nginx/access.log
–http-client-body-temp-path=/var/db/nginx/client_body_temp
–http-proxy-temp-path=/var/db/nginx/proxy_temp
–http-fastcgi-temp-path=/var/db/nginx/fstcgi_temp --with-ipv6
–with-mail_ssl_module --with-http_ssl_module --with-http_spdy_module

Thanks

I can’t seem to figure out why this happens… I tough using:

uwsgi_param SCRIPT_NAME /wiki;
uwsgi_modifier1 30;

Would do the trick… but It doesn’t…

Do not use that trick, is pretty outdated and incredibly ugly.

Just let uWSGI do the SCRIPT_NAME rewrite, add the --manage-script-name
to
the option (be sure to use the --mount way for loading moinmoin). The
nginx configuration will be simply

location /wiki {
include uwsgi_params;
uwsgi_pass …;
}


Roberto De Ioris
http://unbit.it

Thanks for the hint… I though passing SCRIPT_NAME was a “ugly” way to
do
into, but since it was refereed in the docs…

I was using mount:
uwsgi -s /tmp/moin.socket --uid nginx --gid nginx --mount
/wiki=/usr/pkg/share/moin/mywiki/moin.wsgi -M -p 2 -d
/var/log/nginx/uwsgi_moin.log --logdate
–pidfile=/var/run/uwsgi_moin.pid

I added --manage-script-name has suggested, now it points to the right
direction… :wink:

It would be nice if the link was updated with this info…

Many thanks,
Mike

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs