Utilizar bash shell para capistrano

Saludos a la lista.

Estoy haciendo deploy de una aplicación con capistrano y tengo un
problema.
Resulta que al momento de hacer deploy quiero parar el servidor ferret y
luego volverlo a reiniciar.
De manera que por allá en el archivo deploy.rb tengo una línea como
esta:

run “cd #{release_path}; script/ferret_server -e production start”

y de la misma forma una para el stop…

el problema radica en que según
http://projects.jkraemer.net/acts_as_ferret/wiki/DrbServer en el tema
“On
your server” dice que ese comando solo funciona con bash, no con sh.

ok… me fuí al archivo /etc/passwd y cambié el shell para el usuario que
hace el deploy pero nada al parecer sigue usando el shell sh.

No sé si exista una directiva de capistrano para poner el shell que se
quiere usar durante el deploy ó si existe una forma de “settear” el
shell a
nivel del sistema.

Gracias.

Una pequeña chapucilla es usar:
run “bash -c cd #{release_path}; script/ferret_server -e production
start”

Esto invoca a bash ejecutando lo que sigue a -c como comando.

No se si después de cambiar la shell en /etc/passwd debes salir de las
sesiones abiertas.

2008/4/8, Luis Felipe Hurtado C. [email protected]:

Si cambias el archivo /etc/password y le pones como shell /bin/bash
debería
de funcionar, ten en cuenta que debes salir de la sesión y volver a
entrar
como comenta Dani. Comprueba también los permisos.

El día 9/04/08, Dani D. [email protected] escribió:

No lo he probado, pero creo que es así.

Para hacerlo de manera global:
default_run_options[:shell] = ‘bash’

o solo en alguna acción:

run “ls”, :shell => ‘bash’

Saludos

Luis Felipe Hurtado C. escribió:

El comando run no usa la shell del usuario, por defecto usa sh y se
asegura que es una shell POSIX.

capistrano-2.2.0$ grep “sh” -r .
./lib/capistrano/command.rb: shell = “#{options[:shell]
|| “sh”} -c”

Saludos

Emili Parreño escribió:

Increíble:

http://projects.jkraemer.net/acts_as_ferret/ticket/185

Me bajé entonces desde el trunk el archivo server_manager.rb y probé y
funcionó.

Gracias igualmente por su interés y por sus respuestas.

Saludos desde Colombia,

Luis Felipe Hurtado.

2008/4/8, Luis Felipe Hurtado C. [email protected]:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs