USRP2 with Realtek r8169 Problem

Hi all,

I just received my USRP2 and hooked it up to a three month old Thinkpad
Edge 13 intel with Realtek ethernet Chipset.

System is: Ubuntu 10.04 LTS Lucid Lynx
Firmware: txrx_wbx_raw_eth_20100608.bin
FPGA-FW: u2_rev3-20100603.bin
Daughterboard: WBX

When i run the fft application with with sudo usrp2_fft.py -f98e6
I get overruns “SSSSSSS” and the GUI hangs.

Changing the decimation does not help.
The USRP2 is operating as I can clearly see the local FM-Stations in the
spectrum.

Older Threads suggested problems with inserted pauses. When checking
with ethtool I get:

Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Link partner advertised link modes: 1000baseT/Half 1000baseT/Full
Link partner advertised pause frame use: No
Link partner advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
Link detected: yes

And with nm-tools I get

  • Device: eth0 [USRP Link]

Type: Wired
Driver: r8169
State: connected
Default: no
HW Address: C8:0A:A9:25:64:5E

Capabilities:
Carrier Detect: yes
Speed: 1000 Mb/s

Wired Properties
Carrier: on

IPv4 Settings:
Address: 192.168.10.1
Prefix: 24 (255.255.255.0)
Gateway: 0.0.0.0

This looks OK to be.

I do not get problems when transmitting.

Do you any suggestion for a fix?
Unfortunately, I do not have another computer here to try out other
setups.

Thanks in advance,
Soeren

On 07/16/2010 08:30 AM, Soeren Peik wrote:

When i run the fft application with with sudo usrp2_fft.py -f98e6
Supported ports: [ TP MII ]
Link partner advertised pause frame use: No
Link detected: yes
HW Address: C8:0A:A9:25:64:5E
Prefix: 24 (255.255.255.0)

[email protected]
http://lists.gnu.org/mailman/listinfo/discuss-gnuradio

I did some more research and kind of fixed the problem. The problem is
twofold. The Realtek driver is bad, as mentioned often here in the
list. Try to avoid it when you can. I am stuck with it and get very bad
performance. However it works with lower data rates, e.g. decimation of
50 or more. Do not run any other programs in parallel. Even by moving
the mouse I get dropped packages.

The issue of the hanging fft-graph can be fixed by reducing the fft-size
to 512 or 256. Then the gui remains responsive.

Soeren

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs