USRP2 start/stop issues redux

I’m having a problem similar to the one discussed in this thread:

http://lists.gnu.org/archive/html/discuss-gnuradio/2009-09/msg00002.html
aka http://www.ruby-forum.com/topic/194488

If I run the test program from that post, it works sometimes, but
occasionally an assertion goes off as shown in the terminal output
below.

In my own application (a C++ app based on rx_streaming_samples.cc), I’m
stepping through a sequence of frequencies. For each frequency, I set
the center frequency, start streaming, buffer up some samples, stop
streaming, write the samples to disk and go around again. It works for a
few frequencies and then (not always on the same iteration)
stop_rx_streaming fails. After that, setting the center frequency always
fails.

The thread above says the problem was fixed and the fix was moved to the
master branch. I’m running gnuradio 3.3.0. Do I need to pull another
branch?

-Marc

[email protected]:~/Desktop$ ./usrp2_test.py
python: /usr/include/boost/thread/pthread/mutex.hpp:50: void
boost::mutex::lock(): Assertion !pthread_mutex_lock(&m)' failed. Aborted [email protected]:~/Desktop$ ./usrp2_test.py [email protected]:~/Desktop$ ./usrp2_test.py [email protected]:~/Desktop$ ./usrp2_test.py python: /usr/include/boost/thread/pthread/mutex.hpp:50: void boost::mutex::lock(): Assertion!pthread_mutex_lock(&m)’ failed.
Aborted
[email protected]:~/Desktop$ ./usrp2_test.py
[email protected]:~/Desktop$ ./usrp2_test.py
[email protected]:~/Desktop$ ./usrp2_test.py
python: /usr/include/boost/thread/pthread/mutex.hpp:50: void
boost::mutex::lock(): Assertion `!pthread_mutex_lock(&m)’ failed.
Aborted
[email protected]:~/Desktop$

I’ve solved the problem with my own app. My sample handler had an
uninitialized member and was sometimes finished before it started.

The test app from the previous thread still has the failing assertion,
but that might be a red herring.

-Marc

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs