USRP2 slave PPS signal over the MIMO cable

I would like to run two USRP2’s as master and slave, and I would like to
only use a 1PPS on the master (each USRP2 would be controlled by
two separate processes). When I run the test_pps_input on the slave,
the
program fails. However, the master is able to find the PPS just fine.
I’ve
tried a combination of running the master, then running the
slave/running
the master at the same time as the slave/running the slave then the
master/etc with no luck. I think short of probing the pins on the MIMO
cable or perusing the FPGA code (which I believe is not available to the
public), I’m pretty much out of ideas.

One thought I had was that adjusting from clock_config_t::internal to
external might help, but on further review of the code, the PPS does not
appear to be affected by this. I have seen some posts about this, but
none
after January 20th (the most recent UHD announcement about MIMO
upgrades).
Any

Thanks in advance,

David

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs