USRP2-No USRPs found on interface eth0

Hi All,

I’m testing my USRP2. I run ./usrp2_fft.py and ./usrp2_wfm_rcv.py, both
worked fine. However, I got an error now, “RuntimeError: No USRPs found
on
interface eth0”. I didn’t change anything on this computer. I connect
the
USRP2 on another computer, all work fine. Could anyone advise me on how
to
solve this problem? What causes this error? Thanks in advance.

-Brook


View this message in context:
http://old.nabble.com/USRP2-No-USRPs-found-on-interface-eth0-tp27346326p27346326.html
Sent from the GnuRadio mailing list archive at Nabble.com.

Immediately above “Traceback (most recent call last):” in the command
window
is there any error?

The most common I get are:

[email protected]:~$ usrp2_fft.py
eth0: SIOCGIFINDEX: No such device

or

[email protected]:~$ usrp2_fft.py -e eth1
socket(PF_PACKET, SOCK_RAW, htons(0xBEEF)): Operation not permitted
eth1: socket: No such file or directory


In the former case for some reason my ubuntu install randomly changed
eth0
to eth1 , run ifconfig and try:

usrp2_fft.py -e ethX

where X is the number listed in ifconfig | grep eth

If you get the second error for some reason usrp2_socket_opener has lost
permissions (or you’ve been running as root when it worked in the past)

sudo chmod +s /usr/bin/usrp2_socket_opener

Should fix this problem.

Last idea is if you’ve tried the VRT firmware/gnuradio code on the other
PC
– the control packets have changed in this release so wont work with
stock
git/packaged gnuradio versions.

Cheers,

Tim

Thanks, Tim. The error I got is

~/gnuradio/gnuradio-examples/python/usrp2$ sudo ./usrp2_wfm_rcv.py -e
eth0
Traceback (most recent call last):
File “./usrp2_wfm_rcv.py”, line 274, in
app = stdgui2.stdapp (wfm_rx_block, “USRP2 WFM RX”)
File
“/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py”,
line 36, in init
wx.App.init (self, redirect=False)
File
“/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_core.py”,
line 7836, in init
self._BootstrapApp()
File
“/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_core.py”,
line 7433, in _BootstrapApp
return core.PyApp__BootstrapApp(*args, **kwargs)
File
“/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py”,
line 39, in OnInit
frame = stdframe (self.top_block_maker, self.title, self._nstatus)
File
“/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py”,
line 60, in init
self.panel = stdpanel (self, self, top_block_maker)
File
“/usr/local/lib/python2.5/site-packages/gnuradio/wxgui/stdgui2.py”,
line 81, in init
self.top_block = top_block_maker (frame, self, vbox, sys.argv)
File “./usrp2_wfm_rcv.py”, line 69, in init
self.u = usrp2.source_32fc(options.interface, options.mac_addr)
File “/usr/local/lib/python2.5/site-packages/gnuradio/usrp2.py”, line
501,
in source_32fc
return _usrp2.source_32fc(*args, **kwargs)
RuntimeError: No USRPs found on interface eth0

The output of ifconfig |grep eth is
"eth0 Link encap:Ethernet HWaddr 00:17:a4:eb:e0:ee "

And I also tried what you mentioned above. However, I still had the same
error. Any advice?

Thanks,
Brook

Tim P.-2 wrote:

or
usrp2_fft.py -e ethX
Last idea is if you’ve tried the VRT firmware/gnuradio code on the other

Discuss-gnuradio mailing list
[email protected]
http://lists.gnu.org/mailman/listinfo/discuss-gnuradio


Discuss-gnuradio mailing list
[email protected]
http://lists.gnu.org/mailman/listinfo/discuss-gnuradio


View this message in context:
http://old.nabble.com/USRP2-No-USRPs-found-on-interface-eth0-tp27346326p27349005.html
Sent from the GnuRadio mailing list archive at Nabble.com.

On Wed, Jan 27, 2010 at 04:02:08PM -0800, Brook L. wrote:

Thanks, Tim. The error I got is

~/gnuradio/gnuradio-examples/python/usrp2$ sudo ./usrp2_wfm_rcv.py -e eth0
Traceback (most recent call last):

File “/usr/local/lib/python2.5/site-packages/gnuradio/usrp2.py”, line 501,
in source_32fc
return _usrp2.source_32fc(*args, **kwargs)
RuntimeError: No USRPs found on interface eth0

The output of ifconfig |grep eth is
"eth0 Link encap:Ethernet HWaddr 00:17:a4:eb:e0:ee "

And I also tried what you mentioned above. However, I still had the same
error. Any advice?

(1) Cycle power on the USRP2 and try again

(2) Be sure that you’ve really got a gigabit ethernet interface.
The USRP2 only speaks gigE, not 10Mb/s, not 100Mb/s.

Eric

Eric B. wrote in post #884199:

On Wed, Jan 27, 2010 at 04:02:08PM -0800, Brook L. wrote:

Thanks, Tim. The error I got is

~/gnuradio/gnuradio-examples/python/usrp2$ sudo ./usrp2_wfm_rcv.py -e eth0
Traceback (most recent call last):

File “/usr/local/lib/python2.5/site-packages/gnuradio/usrp2.py”, line 501,
in source_32fc
return _usrp2.source_32fc(*args, **kwargs)
RuntimeError: No USRPs found on interface eth0

The output of ifconfig |grep eth is
"eth0 Link encap:Ethernet HWaddr 00:17:a4:eb:e0:ee "

And I also tried what you mentioned above. However, I still had the same
error. Any advice?

(1) Cycle power on the USRP2 and try again

(2) Be sure that you’ve really got a gigabit ethernet interface.
The USRP2 only speaks gigE, not 10Mb/s, not 100Mb/s.

Eric

Hi Eric
I am using UHD API and facing the same problem as of Tim in-fact my PC
has gigabit ethernet interface still it gives an error No usrps found on
interface eth0 when run the same file i.e. usrp2_wfm_rcv.py -e etho.

Any advice or solution for this problem…??

One more thing is that when i run uhd_find_device.py and
uhd_usrp_probe.py files it works fine without any error. why this so
happening???

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs