USRP2 Ethernet link Issues

Hi Everyone,

I am currently trying to play around with the USRP2, but am not even
able to
connect to it.

I have the latest UHD and GNURadio installed from git running on Ubuntu
10.04.
I’am connecting the USRP directly to the Gigabit Interface on my
computer.

I used the Firmware/FPGA image from
http://www.ettus.com/downloads/uhd_images/UHD-images-most-recent/

When I switch on the USRP2, all the LED’s light up and then LED D & F
stay
on. But,
-> None of the lights on the ethernet port light up.

-> uhd_find_devices says:
linux; GNU C++ version 4.4.3; Boost_104000;
UHD_003.20110315195256.3a1ad3f

No UHD Devices Found

-> find_usrps says
No USRP2 found.

-> ethtool eth0 says
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Link partner advertised link modes: Not reported
Link partner advertised pause frame use: No
Link partner advertised auto-negotiation: No
Speed: Unknown!
Duplex: Unknown! (255)
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Supports Wake-on: g
Wake-on: d
Link detected: no

-> lspci | grep Ethernet says
03:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5708
Gigabit Ethernet (rev 12)
0a:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721
Gigabit
Ethernet PCI Express (rev 21)

I have two gigabit interfaces, i have tried to connect on both with the
same
result.

-> When I use wireshark to see if any packets are actually sent, I dont
see
anything going between the USRP2 and my computer.

I have set a static ip (192.168.10.1/255.555.255.0) too.
I have tried different ethernet cables, made sure no pins are broken in
either of the ethernet ports.

I’am not sure what I’am doing wrong. I have ferreted the mailing-lists
for
similar problems but couldn’t find any solution. Any help will be
appreciated at this point.

Thanks,
Praveen

On 03/30/2011 06:38 PM, Praveen Vikram wrote:

Hi Everyone,

I am currently trying to play around with the USRP2, but am not even
able to connect to it.

another thing worth checking might be firewall issues and if ping works:
http://www.ettus.com/uhd_docs/manual/html/usrp2.html#communication-problems

-josh

Sorry for the late reply, just got into my lab.

When I start the USRP2, This is what happens:
F lights up first,
then all the LEDS flash
and D and F stay on.

I tried burning txrx_raw_eth_20100608.bin/u2_rev3-20100603.bin as my
fw/fpga
on the SD card and even that does the same thing.
I’am using the Kingston 2gb SD card I got with the USRP2.

Praveen

Thanks again Josh.

I re-flashed the the SD card with the images from:
http://www.ettus.com/downloads/uhd_releases/003_000_000/images
http://www.ettus.com/downloads/uhd_releases/003_000_000/images/I
downloaded the corresponding .deb file and installed it using dpkg.
Set the UHD_IMAGE_PATH to /usr/share/uhd/images (where the .deb file
installed the bin files to)

Now when I turn on the USRP2, the LED’s light up in the same sequence as
in
the video, with one change.
The green light on the left of the Ethernet lights up faintly before the
LED
sequence and goes out.

Still no messages from the USRP2 on wireshark and am not able to find
any
UHD devices either.

but when I typed dmesg on my computer after opening up wireshark it
showed
this:
[10100.838314] dumpcap uses obsolete (PF_INET,SOCK_PACKET)
[10113.980644] device eth0 entered promiscuous mode
[10309.030910] bnx2: eth0 NIC Copper Link is Down

Is there something wrong with my gigabit interface driver?
or Is my USRP2 bricked (is this possible)?

Thanks again for the help,
Praveen

Hello,I can not ping usrp N210 when I config my PC with 192.168.10.1,
Now I have installed gnuradio but not udh, and I also want to know what
is udh for?
Thank you very much!!

On 03/31/2011 09:29 AM, Praveen Vikram wrote:

This may help: when using the images found here:
http://code.ettus.com/redmine/ettus/projects/uhd/wiki

“”"
This is how the LEDs should light up after power cycle when using the
UHD images on your USRP2. Notice at the very end of the video how the
ethernet link light comes on (very faint LED on the left).
“”"
http://www.youtube.com/watch?v=REDK7M-83WQ

Hope that helps,
-Josh

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs