USRP2 Diagnostics in GRC

Hi,

I have a problem concerning USRP2. I am using GRC to make flow graphs
but I can not find USRP2 when I use USRP source block. When I run a
simple program with only two blocks (USRP source and Scope Sink) I get
following error:

Verbose:
usrp: failed to find usrp[0]
Traceback (most recent call last):
File “/usr/share/grc/src/ExecFlowGraphGUI.py”, line 231, in OnInit
self.SetTopWindow(FlowGraphFrame(self.flow_graph_file_path))#first
argument is the flow graph
File “/usr/share/grc/src/ExecFlowGraphGUI.py”, line 159, in init
FlowGraphBuilder.init(self, file_path)
File “/usr/share/grc/src/ExecFlowGraph.py”, line 50, in init
self._parse_nested_data(ParseXML.from_xml(ParseXML.from_file(file_path)))
File “/usr/share/grc/src/ExecFlowGraph.py”, line 145, in
_parse_nested_data
signal_blocks_dict[signal_block.get_id()] =
runnable_signal_block(*data_type_params)
File “/usr/share/grc/src/SignalBlockDefs/USRP.py”, line 182, in make
u = type.parse()[0](number, nchan=1)
File “/usr/lib/python2.6/site-packages/gnuradio/usrp/usrp_swig.py”,
line 1699, in source_c
return _usrp_swig.source_c(*args, **kwargs)
RuntimeError: can’t open usrp

I also tried using USRP Diagnostics in Help menu but it also does nt
detect.
I run find_usrps through terminal and it works like,
00:50:c2:85:34:6f hw_rev = 0x0400

Regards,
Umair N.
MSc Communication Engineering
Chalmers University ot Technology, Sweden.

Umair

It seems to me you are using the USRP block when you should be using
the USRP2.
If not… which version of Gnuradio are you using?

Charles

Wow, how did you find this ancient version of grc?

Anyway, here is the note from my website:

Please use the grc that is bundled with the current gnuradio master or
the gnuradio 3.2 release. It has a years worth of work and improvements
compared to the last versioned release of grc (0.70). In addition, the
grc bundled with gnuradio is guaranteed to evolve with gnuradio; whereas
the older non-bundled grc will stagnate and cease to be compatible with
newer gnuradio releases.

and wiki page

http://gnuradio.org/redmine/wiki/gnuradio/GNURadioCompanion

-Josh

From what I understand, GRC is bundled with the gnuradio 3.2 release.
So you shouldnt need to install this “GRC version 0.7” package. Use the
grc that comes bundled with gnuradio, anything else will have problems
working.

If your package manager cannot give you what you need, I recommend just
installing the gnuradio from source code
http://gnuradio.org/redmine/wiki/gnuradio/BuildGuide

-Josh

I am using GRC version 0.7. I installed from Add/Remove Programs. I have
Gnuradio 3.2 as shown in Add/Remove Programs. How can i upgrade my
GNU/GRC installation to work with USRP2?

Regards,
Umair N.
MSc Communication Engineering
Chalmers University ot Technology, Sweden.


From: [email protected]lid
[[email protected]lid] on behalf
of Josh B. [[email protected]]
Sent: Wednesday, March 31, 2010 5:08 PM
To: [email protected]
Subject: Re: [Discuss-gnuradio] USRP2 Diagnostics in GRC

Wow, how did you find this ancient version of grc?

Anyway, here is the note from my website:

Please use the grc that is bundled with the current gnuradio master or
the gnuradio 3.2 release. It has a years worth of work and improvements
compared to the last versioned release of grc (0.70). In addition, the
grc bundled with gnuradio is guaranteed to evolve with gnuradio; whereas
the older non-bundled grc will stagnate and cease to be compatible with
newer gnuradio releases.

and wiki page

http://gnuradio.org/redmine/wiki/gnuradio/GNURadioCompanion

-Josh

On 03/31/2010 07:19 AM, Umair N. wrote:

 FlowGraphBuilder.__init__(self, file_path)

Discuss-gnuradio mailing list

http://lists.gnu.org/mailman/listinfo/discuss-gnuradio


Discuss-gnuradio mailing list
[email protected]
http://lists.gnu.org/mailman/listinfo/discuss-gnuradio

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs