Usrp1 + rfx900) + atr

Hi,

I am using 2 x (USRP1 + RFX900) for simple transceiver test (USRP1 to
USRP2 back to USRP1), and can successfully transmit OOK packet (preamble

  • payload) and receive response.

However, if I enable ATR on the sender, the received response by the
sender is corrupted (I successfully correlate preamble, but following
payload is corrupted). It’s as if the received signal level becomes
reduced after the ATR switches, or the sampling becomes off cut.

Basically, the simple transceiver works, until Automatic Transmit
Receive switch is enabled. I would like the transmitter to switch on
only when transmitting, thus removing the LO breakthrough when in a
quiescent state.

Is there timing constraints I should adhere to, is there any further
info on use of ATR I could be pointed to,

Thank you,
David.

On Mon, Aug 31, 2009 at 01:22:09PM +0100, David E. wrote:

Hi,

I am using 2 x (USRP1 + RFX900) for simple transceiver test (USRP1 to
USRP2 back to USRP1), and can successfully transmit OOK packet (preamble

  • payload) and receive response.

However, if I enable ATR on the sender, the received response by the
sender is corrupted (I successfully correlate preamble, but following
payload is corrupted). It’s as if the received signal level becomes
reduced after the ATR switches, or the sampling becomes off cut.

I suspect that not all of your transmitted burst is getting out.
You need to append enough zeros to the data to ensure that it’s
flushed out of the FPGA DSP pipeline before the transmitter switches
over.

Eric

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs