USRP usb cable question


#1

Hi

My earlier usb problem seems to be related to the cable I was using. I
tried my home printer’s cable and it began to work. I could load the
firmware and the standard tx and rx programs worked perfectly. I tried
out the usrp_fft.py script. It worked initially and then I got a stream
of usb protocol errors which caused the script to crash. When I tried to
reconnect the board I saw that I was back to square one with the USRP
failing to connect. I also noticed that even though the script crashed
and the was no longer running, the USRP was still drawing just over 1A.

My question is: Is there any way or situation where communication
between the USRP and the pc could cause the usb cable to be damaged? I
haven’t tried another cable yet, because I’m uncertain if the same thing
would happen again.

I did rmmod ehci_hcd and connected the USRP to the same port. I could
succesfully connect and load firmware. I assumes this means that the
USB2 pci card is working and that the cable can still do USB1.1
connections and that the USRP is fine as well. Is there a very specific
kind of USB2 cable I should be using? A shielded type or something?

Regards

Lance