USRP timing offset

Hi everyone!

I’m new to Gnuradio e USRP. I use a USRP N210 with WBX daughterboards
and
loop back cable to connect TX e RX. I have tested USRP with a simple
flowgraph (sine , usrp_sink , usrp_source) and I have observed that the
output signal from usrp_source block is time shifted. I mean, the
usefull
output signal starts after 0.0105 seconds. How can avoid this? I have
tried
to use “issued_stream_cmd”, setting time_spec=0.0105 s but nothing has
changed.

I want to use this USRP in a more complex project and I need to remove
this
initial time-shift.

I attach a plot of input and output signal and my flowgraph.

Thanks in advance for help,

Leo

Hi Leonard,

you should try to use set_start_time(time_spec_t(x)) on both the USRP
sink and source, but only after setting a device time using
set_time_now() before, that should be sufficiently (>0.1s) earlier than
x, before you start the flow graph.

Best regards,
Marcus

Thank you Marcus for help!

Now I’ m using Usrp with SCFDMA chain. I set_time_now and start_time_now
:

uhd_usrp_source.set_time_now (uhd.time_spec_t(time.time()))
uhd_usrp_source.set_start_time(uhd.time_spec_t(time.time()+0.6))
uhd_usrp_sink.set_start_time(uhd.time_spec_t(time.time()+0.6))

and I haven’t time shift.

But I see a lot of “L” (late packet) printed and some “U” (underflow).
How
can solve the problem? I have tried to use low sample rate but after few
seconds L and U appear.

Thanks

Leo

2015-09-02 16:41 GMT+02:00 Leonard F. [email protected]:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs