./usrp_rx_cfile capture and ./benchmark_rx capture differs in bit-rate set even with same parameters

Dear list,
I have a question. I just want to make sure I am not hallucinating
infront
of my comp here. I run this script as follows:

  1. ./usrp_rx_cfile.py -f 2.4G -d 128 foo.dat @ the receiver
    => I get, the bitrate set to 500k

But, when I run this script as follows:
2. //benchmark_rx.py -f 2.4G -d 128 @ the receiver
=> I get the bitrate set to 250k.

Even though, both has decimate rate set to the same, 128.

Problem is, I am running “./benchmark_tx.py -f 2.4G -i 256
–from-file=foo.txt” on the receiver side, and it sets my bitrate to
250k as
expected. I would like to get the same bitrate at the receiver side when
running “usrp_rx_cfile capture [see 1]”, with (interpolation/decimate)
still
being equal to 2. Because I want 2 samples per symbol. Can somebody tell
me
if there is anything obvious about this that i am doing wrong or a
parameter
configuration that I can pass which will do what i need. Let me know if
I
need to give more details of the purpose. Thank you very much.

Sincerely,

On Tue, Sep 15, 2009 at 07:17:45PM -0400, Bishal T. wrote:

Dear list,
I have a question. I just want to make sure I am not hallucinating infront
of my comp here. I run this script as follows:

  1. ./usrp_rx_cfile.py -f 2.4G -d 128 foo.dat @ the receiver
    => I get, the bitrate set to 500k

It looks like you are confusing bitrate and sample rate.
There’s no “bitrate” with usrp_rx_cfile. What you get is a sample
rate of 500k samples/s

But, when I run this script as follows:
2. //benchmark_rx.py -f 2.4G -d 128 @ the receiver
=> I get the bitrate set to 250k.

By default you’re using BPSK (1 bit / symbol), but the receiver needs
at least two samples / symbol to handle synchronization issues. Thus
you’ve got a baseband sample rate of 500kS/s, but a bit rate of
250kb/s

Even though, both has decimate rate set to the same, 128.

Problem is, I am running “./benchmark_tx.py -f 2.4G -i 256
–from-file=foo.txt” on the receiver side, and it sets my bitrate to 250k as
expected. I would like to get the same bitrate at the receiver side when
running “usrp_rx_cfile capture [see 1]”, with (interpolation/decimate) still
being equal to 2. Because I want 2 samples per symbol. Can somebody tell me
if there is anything obvious about this that i am doing wrong or a parameter
configuration that I can pass which will do what i need. Let me know if I
need to give more details of the purpose. Thank you very much.

Eric

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs