USRP N210 overflows in virtual machine using GnuRadio

I am using the USRP N210 through a Debian (4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u1) VM and run very quickly into processing overflow. GnuRadio-Companion is printing the letter “D” the moment one of the CPUs load is reaching 100 %. This was tested by increasing the number of taps for a low-pass filter, as shown in the picture with a sampling rate of 6.25 MHz.

I have done all instructions on How to tune an USRP, except the CPU governor. This is because I am not able to do this due to a missing driver reported by cpufreq-info. The exact output is

No or unknown cpufreq driver is active on this CPU.

The output of the lscpu command is also shown in a picture.

Has anyone an idea how I can resolve the problem? Or is GnuRadio just not fully supported for VMs?

image

I’ve tried that years ago … even with XCP virtual host … same result
I think the problem is the low performance of the visualized USB 3.0 port

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs