USRP N200 with GNU v3.7 fails

Hi People,

My system Ubuntu 13.04
GNURADIO 3.7.1.1
USRP N200

I run:

cd /usr/local/src
sudo wget
https://sites.google.com/site/byungchulweb/gnufile/UHD_003.003.000.tar.gz
sudo tar xvf UHD_003.003.000.tar.gz
cd uhd/host
mkdir build
cd build
cmake …/
make
make test
sudo make install
sudo ldconfig


Then:
sudo apt-get install uhd-host

It installs:
uhd-host 3.4.2-1
with
libgnuradio-uhd3.6.1 3.6.1-1


then I run:
sudo ifconfig eth0 192.168.10.1
uhd_usrp_probe

linux; GNU C++ version 4.7.3; Boost_105300; UHD_003.003.000-unknown
– Opening a USRP2/N-Series device…
Error: RuntimeError:
Please update the firmware and FPGA images for your device.
See the application notes for USRP2/N-Series for instructions.
Expected protocol compatibility number [7 to 11], but got 12:
The firmware build is not compatible with the host code build.

  1. The first question is why does it load libgnuradio-uhd3.6.1
    3.6.1-1 instead of 3.7 version?
  2. it was working with GNURADIO 3.6 before, now it fails with v3.7, why?
  3. How can I solve the last error message?

Thanks in advance!

Thanks Marcus,

Should I delete libgnuradio-uhd3.6.1 3.6.1-1 , and install gnuradio
v3.7 again?

Пятница, 22 ноября 2013, 18:00 UTC от Marcus L. [email protected]:


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

Thanks! It worked:

wget http://www.sbrac.org/files/build-gnuradio && chmod a+x
./build-gnuradio && ./build-gnuradio

Пятница, 22 ноября 2013, 18:09 UTC от Marcus L. [email protected]:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs