USRP_N200 unable to connect via vmplayer

I have vmplayer virtual machine running on my computer as my system is
GPT
partition style and which is not taking dual boot of any release of
ubuntu.

I connect to an ethernet port to a USRP rx… and do a uhd_find_devices

it says no device found… although I have a valid gnuradio distro +uhd
on
my computer and it works fine when I am not using the USRP though…

Could it be because of the vm that I am using? Please suggest what do I
need to do!!

this is my eth0 config-

eth0 Link encap:Ethernet HWaddr 00:0c:29:23:94:4e
inet addr:192.168.10.1 Bcast:192.168.10.255
Mask:255.255.255.0
inet6 addr: fe80::20c:29ff:fe23:944e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:39419 errors:0 dropped:0 overruns:0 frame:0
TX packets:14888 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:48827305 (48.8 MB) TX bytes:1521561 (1.5 MB)
Interrupt:19 Base address:0x2000

This shows up when I am doing my firmware update-

[email protected]:~/Downloads/uhd-images_003.005.001-release/share/uhd/images$
usrp_n2xx_simple_net_burner --addr 192.168.10.3 --fw usrp_n200_fw.bin
–fpga usrp_n200_r3_fpga.bin --auto_reboot
linux; GNU C++ version 4.6.3; Boost_104800; UHD_003.005.003-78-g49a4929b

Searching for USRP N2XX with IP address 192.168.10.3.
Error: No USRP N2XX found.

my machine is 192.168.10.1 … the usrp is on 192.168.10.3 via same
ethernet
sw

-Regards,
Ankan R.
University of Florida.


… it says no device found… although I have a valid gnuradio distro
inet6 addr: fe80::20c:29ff:fe23:944e/64 Scope:Link

-Regards,
Ankan R.
University of Florida.

You’re sure its not at the default address 192.168.10.2?

Don’t know if you have the same problem but I use a USB to GigE adapter
from vmware player and I found that it ONLY works if I boot the VM with
the interface that is connected to the USRP as the only active network
connection. I can enable the network interface to the host OS after I
boot and it still works but for some reason if the VMnetX interfaces are
active at boot it messes up the ability to find the USRP.

-Clark

Hi,
Check if your usrp is surely on 192.168.10.3. Run uhd_usrp_probe and
check if it is giving any output. Do you have gigabit ethernet card on
your
laptop. If not, you will have to use a switch in between and some times
switch might be an issue.

one more thing, are you connected on static ip? If you are on dhcp,
change
it to static ip and see.

  1. I tried using vm bridged connection over NAT… i assigned
    192.168.10.1
    and subnet 255.255.255.0 in the ubuntu network setting running on
    vmplayer… I am pretty much sure about the other USRP IP since… i used
    some other machine to do uhd_find_devices … so check for their IPs…
  2. My ethernet port is working fine on windows… I though did not check
    it
    on my vm… bt hopefully it is working since it is recognizing the LAN…
  3. The sw is perfectly fine tested OK.
  4. I changed it from dhcp to manual ipv4 settings as 1. the problem
    persists… the device is on 192.168.10.3…
    i did uhd_usrp_probe with --args=… it says the same.
    could not find devices…

I feel there is a big issue with the vmplayer network settings with
uhd…

-Ankan R…

On 06/11/2013 02:19 AM, Ankan R. wrote:

could not find devices…

I feel there is a big issue with the vmplayer network settings with uhd…

Well, can you ping the USRP from the VM? That would eliminate the
question of uhd and UDP sockets.

Can you ping another device with a static IP though the VM, like a
router that is connected to the same network interface as the USRP?

-josh