USRP harware problem?


#1

we have 2 usrp boxes. 1 now doesn’t work, only 2 works. we use 3 steps
to
check if it is the hardware problem:

step 1) recognized by linux?

on good box:
lsusb
Bus 007 Device 001: ID 0000:0000
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 001 Device 004: ID 413c:3012 Dell Computer Corp.
Bus 001 Device 003: ID 413c:2003 Dell Computer Corp.
Bus 001 Device 001: ID 0000:0000
Bus 006 Device 012: ID fffe:0002
Bus 006 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
on bad box:
lsusb
Bus 007 Device 001: ID 0000:0000
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 001 Device 004: ID 413c:3012 Dell Computer Corp.
Bus 001 Device 003: ID 413c:2003 Dell Computer Corp.
Bus 001 Device 001: ID 0000:0000
Bus 006 Device 013: ID 04b4:8613 Cypress Semiconductor Corp. CY7C68013
EZ-USB FX2 USB 2.0 Development Kit
Bus 006 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000

seems bad box is recognized??

View this message in context:
http://www.nabble.com/USRP-harware-problem--tp20629596p20629596.html
Sent from the GnuRadio mailing list archive at Nabble.com.


#2

step 2) proper device driver loaded and device entry created in /dev ?

good box:
/dev/bus/usb$ ls -l
total 0
drwxr-xr-x 2 root root 100 2008-11-14 17:04 001
drwxr-xr-x 2 root root 60 2008-11-14 17:04 002
drwxr-xr-x 2 root root 60 2008-11-14 17:04 003
drwxr-xr-x 2 root root 60 2008-11-14 17:04 004
drwxr-xr-x 2 root root 60 2008-11-14 17:04 005
drwxr-xr-x 2 root root 80 2008-11-21 12:59 006
drwxr-xr-x 2 root root 60 2008-11-14 17:04 007

bad box:
/dev/bus/usb$ ls -l
total 0
drwxr-xr-x 2 root root 100 2008-11-14 17:04 001
drwxr-xr-x 2 root root 60 2008-11-14 17:04 002
drwxr-xr-x 2 root root 60 2008-11-14 17:04 003
drwxr-xr-x 2 root root 60 2008-11-14 17:04 004
drwxr-xr-x 2 root root 60 2008-11-14 17:04 005
drwxr-xr-x 2 root root 80 2008-11-21 13:00 006
drwxr-xr-x 2 root root 60 2008-11-14 17:04 007

View this message in context:
http://www.nabble.com/USRP-harware-problem--tp20629596p20629620.html
Sent from the GnuRadio mailing list archive at Nabble.com.


#3

step 3) the control software access the device entry correctly?

good box
/gnuradio/gnuradio/gnuradio-examples/python/usrp$
./usrp_benchmark_usb.py
Testing 2MB/sec… usb_throughput = 2M
ntotal = 1000000
nright = 999452
runlength = 999452
delta = 548
OK
Testing 4MB/sec… usb_throughput = 4M
ntotal = 2000000
nright = 1999583
runlength = 1999583
delta = 417
OK
Testing 8MB/sec… usb_throughput = 8M
ntotal = 4000000
nright = 3998943
runlength = 3998943
delta = 1057
OK
Testing 16MB/sec… usb_throughput = 16M
ntotal = 8000000
nright = 7999584
runlength = 7999584
delta = 416
OK
Testing 32MB/sec… usb_throughput = 32M
ntotal = 16000000
nright = 15998150
runlength = 15998150
delta = 1850
OK
Max USB/USRP throughput = 32MB/sec

bad box:
/gnuradio/gnuradio/gnuradio-examples/python/usrp$
./usrp_benchmark_usb.py
Testing 2MB/sec… Traceback (most recent call last):
File “./usrp_benchmark_usb.py”, line 106, in
main ()
File “./usrp_benchmark_usb.py”, line 96, in main
ok = run_test (rate, verbose)
File “./usrp_benchmark_usb.py”, line 63, in run_test
usrp_tx = usrp.sink_s (0, tx_interp)
File “/usr/local/lib/python2.5/site-packages/gnuradio/usrp.py”, line
228,
in init
_ensure_rev2(which)
File “/usr/local/lib/python2.5/site-packages/gnuradio/usrp.py”, line
83,
in _ensure_rev2
v = _look_for_usrp(which)
File “/usr/local/lib/python2.5/site-packages/gnuradio/usrp.py”, line
77,
in _look_for_usrp
raise RuntimeError, “Unable to find USRP #%d” % (which,)
RuntimeError: Unable to find USRP #0

can anybody help us out? thanks a lot!

View this message in context:
http://www.nabble.com/USRP-harware-problem--tp20629596p20629647.html
Sent from the GnuRadio mailing list archive at Nabble.com.