USRP and "fusb: (rd status -71) Protocol error"

Hi

I’ve a rev 3 USRP which has the Flex2400 and TVRX daughtercards
installed.
At one time the setup worked well - altho I’ve let it lie a while. This
week
I’ve swapped out a TVRX and replaced it with the DBSRX in preparation
for a
new project.

When I run usrp_fft.py things are fine for a few moments but inevitably
the
program crashes with:

fusb: (rd status -71) Protocol error

repeatedly written to the terminal. Similar story for usrp_oscope.py and
most other examples.

This occurs both when using the Debian packages (3.0.2-2). When using
the
latest subversion build I sometimes get the error during the
test_usrp_standard_rx “installation” stage but often it works and
produces
results such as:

xfered 1.34e+08 bytes in 4.19 seconds. 3.2e+07 bytes/sec. cpu time =
0.184
noverruns = 0

What is the “Protocol error” error caused by and how can I fix it?

Kind regards,

Steve

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs