Using nginx as a frontend for apache2 serving wordpress w/ super-cache


#1

I am trying to setup nginx as a frontend for apache2 to serve Wordpress
with super-cache. I don’ t want to use this for a production server,
only to speed up my old Athlon 1100 workstation, which moves sometimes
into swapping while using the wordpress admin panel. This is my
workarround:

http://home.arcor.de/nhz6/nginx/default
http://home.arcor.de/nhz6/nginx/nginx.conf

Trying to access http://example.com redirects me to
http://example.com:8080, but the serving of static files by nginx doesn’
t work and i get 301 errors. Trying to access
http://example.com/wp-content/themes/yaml-karo/images/about-me.jpg
redirects me to http://example.com:8080/. Maybe i am missing something
or a typo, don’ t know.

http://home.arcor.de/nhz6/nginx/error.log
http://home.arcor.de/nhz6/nginx/access.log (empty)
http://home.arcor.de/nhz6/nginx/example.com.error.log
http://home.arcor.de/nhz6/nginx/example.com.access.log

It is also bad that only very few nginx --> apache2 howtos exists and
those i’ ve found use very very different ways and all are missing the
apache2 part. Seems to be very simple. I am for example unsure with
these settings

StartServers 5 MinSpareServers 2 MaxSpareServers 5 MaxClients 50 MaxRequestsPerChild 0

I ve also set KeepAlive to Off. Maybe i can modify other options, but i
don’ t know. Appreciate any help. Thanks.


#2

Hello!

On Sat, Jan 24, 2009 at 01:45:48AM -0800, Dieter Zinke wrote:

I am trying to setup nginx as a frontend for apache2 to serve Wordpress with super-cache. I don’ t want to use this for a production server, only to speed up my old Athlon 1100 workstation, which moves sometimes into swapping while using the wordpress admin panel. This is my workarround:

http://home.arcor.de/nhz6/nginx/default
http://home.arcor.de/nhz6/nginx/nginx.conf

Trying to access http://example.com redirects me to http://example.com:8080, but the serving of static files by nginx doesn’ t work and i get 301 errors. Trying to access http://example.com/wp-content/themes/yaml-karo/images/about-me.jpg redirects me to http://example.com:8080/. Maybe i am missing something or a typo, don’ t know.

Serving static from nginx doesnt work due to the following code in
your server configuration:

all other requests go to Wordpress

if (!-e $request_filename) {
rewrite . /index.php last;
}

It’s done at server level and tests file existence without
root specified.

Maxim D.