Using Ant from Ruby


#1

Hi

I am writing a Ruby script to automate some process. Part of it involves
running an ant script ( the java build tool from apache). But, I am
finding it difficult to make it work.

I tried system(‘ant’) but it didn’t work. It just returned a false. I
have
checked that ant is there in my system path.
Another strange thing is that it works when I provide some input or
output
redirections. e.g. if I run system(‘ant > abc.txt’), the command runs.

I also tried ant but that also didn’t work and returned the following
error.
Errno::ENOEXEC: Exec format error - ant

In this case also ant < abc.txt or ant > abc.txt works!!

I am using Windows 2000 machine and have cygwin and 4nt installed. I am
running these commands on irb promt on 4nt.
Can anyone please help me in this regard.

Thanks and regards
Sanchit Misra


#2

On Monday 05 June 2006 17:27, removed_email_address@domain.invalid wrote:

command runs.

I also tried ant but that also didn’t work and returned the
following error.
Errno::ENOEXEC: Exec format error - ant

In this case also ant < abc.txt or ant > abc.txt works!!

I am using Windows 2000 machine and have cygwin and 4nt installed.
I am running these commands on irb promt on 4nt.
Can anyone please help me in this regard.

I guess the “ant” command on Windows resolves to an ant.bat or ant.cmd
file. Others had similar problems with the “system” method.
Try to run:
system “ant.bat”
or
system “ant.cmd”


#3

maybe you can try:

cmd /c ant

removed_email_address@domain.invalid å??é?:


#4

system “ant.bat” worked!! thanks a lot

Sanchit

Stefan L. removed_email_address@domain.invalid
06/05/2006 09:13 PM
Please respond to
removed_email_address@domain.invalid

To
removed_email_address@domain.invalid (ruby-talk ML)
cc

Subject
Re: Using Ant from Ruby

On Monday 05 June 2006 17:27, removed_email_address@domain.invalid wrote:

command runs.

I also tried ant but that also didn’t work and returned the
following error.
Errno::ENOEXEC: Exec format error - ant

In this case also ant < abc.txt or ant > abc.txt works!!

I am using Windows 2000 machine and have cygwin and 4nt installed.
I am running these commands on irb promt on 4nt.
Can anyone please help me in this regard.

I guess the “ant” command on Windows resolves to an ant.bat or ant.cmd
file. Others had similar problems with the “system” method.
Try to run:
system “ant.bat”
or
system “ant.cmd”


#5

cmd /c ant also worked!
thanks

sanchit

ruby-talk ML removed_email_address@domain.invalid
06/05/2006 09:22 PM
Please respond to
removed_email_address@domain.invalid

To
removed_email_address@domain.invalid (ruby-talk ML)
cc

Subject
Re: Using Ant from Ruby

maybe you can try:

cmd /c ant

removed_email_address@domain.invalid å??é?:

Hi

I am writing a Ruby script to automate some process. Part of it involves

running an ant script ( the java build tool from apache). But, I am
finding it difficult to make it work.

I tried system(‘ant’) but it didn’t work. It just returned a false. I
have
checked that ant is there in my system path.
Another strange thing is that it works when I provide some input or
output