UserEngine "puts" warning mess up Apache/FastCGI?


#1

Hi,

My rails app (hosted on Dreamhost) often gives the dreaded “Rails
Application Failed to Start Properly” error when it has been left alone
for
a while. I have a suspicion that this could be due to the fact that I’m
running the Apache/FastCGI-solution, which, according to
http://wiki.rubyonrails.com/rails/pages/Gotcha doesn’t like “puts”
statements at all.

I tend to get warnings such as “Skipping integrity check. You have no
system
roles set up; once your database tables are set up, run rake bootstrap
to
create the basic roles.” even when everything works as it should, and I
am
wondering if user_engine.rb could be modified to only output these
warnings
in development mode, or if a configuration option could be added to omit
all
puts-statements?

Thanks,

Casper F.


Jeg beskyttes af den gratis SPAMfighter til privatbrugere.
Den har indtil videre sparet mig for at fa 1089 spam-mails
Betalende brugere far ikke denne besked i deres e-mails.
Hent en gratis SPAMfighter her http://www.spamfighter.com/go.asp?t=248
.


#2

Please create a ticket on http://dev.rails-engines.org/ about this -
you’re probably right. However, you should probably run the bootstrap
task if you haven’t.

  • james