Upstream module question


#1

Hi all,

with the upstream module, in default mode (WRR), what is the best way
to disable a server from the pool ?

1- simply remove the line
2- add the “down” keyword to the server
3- set server weight to 0 to disable it

Thx for the answers.

++ jerome


#2

On Wed, Jun 03, 2009 at 10:05:21AM +0200, J?r?me Loyet wrote:

Hi all,

with the upstream module, in default mode (WRR), what is the best way
to disable a server from the pool ?

1- simply remove the line

This is.


#3

2009/6/3 Igor S. removed_email_address@domain.invalid:

On Wed, Jun 03, 2009 at 10:05:21AM +0200, J?r?me Loyet wrote:

Hi all,

with the upstream module, in default mode (WRR), what is the best way
to disable a server from the pool ?

1- simply remove the line

This is.

So the others just don’t work ?


#4

On Jun 3, 2009, at 9:42, Jérôme Loyet removed_email_address@domain.invalid wrote:

This is.

So the others just don’t work ?

I expect they do, but nginx still has to parse the line, maintain the
entry in memory, etc.

I just comment out the line when I take a server out, and put a
comment in the file as to why I did it :slight_smile:


#5

2009/6/3 Igor S. removed_email_address@domain.invalid:

1- simply remove the line

This is.

So the others just don’t work ?

They may work but I need to ensure this.
I’ll try some times, don’t waste time with that If you don’t really
want to figure out :slight_smile:


#6

On Wed, Jun 03, 2009 at 10:42:45AM +0200, J?r?me Loyet wrote:

This is.

So the others just don’t work ?

They may work but I need to ensure this.