Upgrading to ruby 1.9.2

i guess this problem (upgrading ruby to 1.9.2) was already discussed
alot, but i couldnt find THE answer for me.

here my situation and what a got so far.

now:
windows 7
ruby 1.8.6
rails 2.3.4
mysql server 5.0.11
everythings running smoothly

now i need to upgrade to ruby 1.9.2 due to some needed features.

upgrade to ruby 1.9.2 but i like to stay with rails 2.3.4 for now
=> problems with utf-8 encoding
==> solved with magic comments (# encoding: utf-8) in the respective
files
=> error with “secure_compare”
==> solved
=> error with “incompatible character encodings: ASCII-8BIT and UTF-8”
==> i googled the prob and got the tip to use “mysql2”-gem
=> error on “gem install mysql2”
==> *.h libraries missing so i upgraded mysql to 5.5.11
=> gem install mysql2 --platform=ruby –
‘–with-mysql-include=“C:…\include” --with-mysql-lib=“C:…\lib”
–no-ri --no-rdoc’ worked
=> since i still use rails 2.3.4 if put this in the environment.rb
“config.gem ‘mysql2’”
=> i copied the libmysql.dll to ruby/bin

BUT now i get:
ArgumentError: NULL pointer given
from (eval):3:in each_hash' from (eval):3:inall_hashes’

help please.
as i figure it: the old mysql-adapter from rails 2.3.4 doesnt work with
mysql 5.5.11, right? solutions?

thanks in advance

never mind … i upgraded to rails 3.0.7 it seems to work.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs