Upgrading to Rails with git v2.3.2 tag


#1

Hi,

This bit me but I haven’t seen it mentioned on here yet. I have Rails
vendored as a submodule so to upgrade from the release candidate to
2.3 I simply pulled and checked out the v2.3.2 tag
(73fc42cc0b5e94541480032c2941a50edd4080c2).

Unfortunately a rather large bug means the nested parameters will not
be hashed when POSTing, e.g. user[name] will be “user[name]” => “bob”
instead of :user => {:name => “bob”}. This is because the gem install
of rack takes precedence instead of the newer bundled one, it’s fixed
in the immediate commit after
(39ff550fa88da9a22d8c21ca872f5e4d0d83f8d4). Pulling from the HEAD of
master is pretty safe at the moment anyway.

Thanks to Matt Jankowski for original report:
http://rails.lighthouseapp.com/projects/8994/tickets/2259-params-hash-issues

Hope this helps someone avoid trouble!

Andrew