Upgrading to 0.7.0-rc2


I attempted an upgrade to 0.7.0-rc2.

I got most everything worked out after I updated my extensions (reorder
& copy_move). However, I get an error when I access the site. Check it
out at http://www.benmorrow.info.

It looks like the server is looking at the 0.6.9 gem rather than the
0.7.0 gem.

I ran both rake radiant:update and rake db:migrate.

Any suggestions?


Remove radiant 0.6.9. Or better, put radiant itself into your
application, don’t rely on the radiant gem.


Joe Van D. wrote:

Remove radiant 0.6.9. Or better, put radiant itself into your
application, don’t rely on the radiant gem.

Ha, it was my bad. I forgot to add the line:

ENV[‘GEM_PATH’] = File.expand_path(’~/.gems’) +

to my environment.rb, which Dreamhost requires for user-installed gems.


I’m using paperclipped with .7rc2 and on my mac’s server is runs
smooth as butter. I pushed it up to my server (Joyent) and I can’t
get the delete asset to work right. When I hit delete I get an
Application error. Three refreshes and the image is gone and
everything is fine. So in the log it says:

[paperclip] Deleting files for asset
[paperclip] -> /users/home/…public/assets/32/cowboy.gif
Errno::EEXIST (File exists - /users/home/…public/assets/32):

and throws up 500.html

If I look at the files one of the images have been deleted

I could hit back and then try to delete it again and another will be
deleted until they are all gone and the app will continue like
everything is fine.

Any ideas why paperclipped isn’t deleting all four images like it




I have not had time to check it with the new release, but there is a
branch for it on github.There was a thread a few days ago. I will try
to get in patched soon.



I really don’t think it is a problem with the new release because it
works perfectly on my mac’s server. I saw the change that was made
and tried making that change too but it didn’t help with my problem.
Maybe something went wrong when I installed it. There is a note in in
the readme file about installing Settings before running the
paperclipped migration. By the way, that note could be more helpful
if it came before you give the paperclipped migration instructions.
In my case, I had already run paperclipped migrations. For good
measure I ran the paperclipped migrations again after I had installed

Should I just start over or is this fixable? Everything seems to work
well except deleting files. I’m just not sure if I caused this
problem by migrating twice or maybe I’m missing something.


The setting migration is only for the descriptions in the Settings
plugin. That has nothing to do with the actual function of the
paperclipped extension. There was a problem with deleting images if
the bucket had never been used, I am pretty sure I squashed that
though. Be sure you have the latest version of the paperclipped
extension from github and then take a look at the production log from
your server, that will tell you what the 500 error is. An older
version of the extension gave me the same problem and the update fixed
it. Let me know if you need more help.