Upgrading Rails to 1.1


#1

So, I’ve upgrade rails to 1.1, and then re-installed my ‘engines’
plugin, and
‘login_engine’ from http://svn.rails-engine.org/plugins/ .

Now, when I run my unit tests, I get an error about “add_path” being
missing.
Following the ‘edge’ directions seems to change (improve?) things, but
should
I still have to say ‘:edge => true’ for 1.1?

David

P.S.


#2

You should not have to specify the :edge => true stuff, no. What do
you get if you type

Rails::VERSION::STRING

in a console?

  • james

On 4/4/06, David C. removed_email_address@domain.invalid wrote:


engine-users mailing list
removed_email_address@domain.invalid
http://lists.rails-engines.org/listinfo.cgi/engine-users-rails-engines.org

  • J *
    ~

#3

My bad. Sorry.


#4

Can you supply the error message in full - the method trace will be
helpful.

  • james

On 13 May 2006 16:45:56 -0000, Domenic Ippolito


#5

Hi, I’m also getting the add_path error in engines.rb.
I’m running rails 1.1.2, and I’ve tried using edge rails and specifying

module Engines
CONFIG = {:edge => true}
end

at the top of my environment.rb file, but it didn’t help.

Rails::VERSION::STRING prints “1.1.2”, which seems right.

I am a long-time Unix guy, but new to ruby/rails, so I might be missing
something basic.

Any insights would be appreciated,

Domenic


#6

Hi James,

I am struggling with the same problem, my trace looks very similar:

/Users/nathan/Documents/epanel-migrate-to-112/config/…/vendor/plugins/engines/lib/engines.rb:163:in
start_engine': undefined methodadd_path’ for Controllers:Module
(NoMethodError)
from
/Users/nathan/Documents/epanel-migrate-to-112/config/…/vendor/plugins/engines/lib/engines.rb:122:in
start' from /Users/nathan/Documents/epanel-migrate-to-112/config/../vendor/plugins/engines/lib/engines.rb:121:instart’
from
/Users/nathan/Documents/epanel-migrate-to-112/config/environment.rb:80

I am running Rails 1.1.2 on OS X using the latest version of Locomotive.

Regards
Nathan


#7

Are you all running with the latest version of the Engines plugin?
Some of those line numbers indicate otherwise…

  • james

#8

James A. wrote:

Can you supply the error message in full - the method trace will be
helpful.

  • james

On 13 May 2006 16:45:56 -0000, Domenic Ippolito

James,

Here’s the message/trace:

vendor/plugins/engines/lib/engines.rb:163:in start_engine': undefined methodadd_path’ for Controllers:Module (NoMethodError)
from vendor/plugins/engines/lib/engines.rb:122:in start' from vendor/plugins/engines/lib/engines.rb:121:instart’
from ./…/config/environment.rb:75
from dispatch.rb:3

Thanks,

Domenic


#9

I had a similar trace when I downloaded the demo of RikiEngine_0_3_2.
I have
actionpack-1.12.1
rails-1.1.2
activerecord-1.14.2

I did try, as you suggest, upgrading the engine plugin.
I also tried upgrading user_engine and login_engine.

The result was catastrophic, even more error messages spewed.
It was now complaining about what seemed to be the innards of the Oracle
and FCGI adapters, among many things.

I gave up.
Until I saw this thread.

I really like the IDEA of the packaging that ‘engines’ represents, but
there does seem to be problems with the deployment.


#10

Sadly your blog was not a lot of use.
I’m just trying to get this to run as a demo on my own Linux server with
WebBrick. No FCGI, no Apache. ZILCH.
So the stuff about .htaccess, Dreamhost, deployment etc is not relevant.

I’m trying to do the bare minimum to get this to work, not deploy it
“in the wild”. I’m trying to solve the very basic problem.

Yes I tried the
CONFIG = {:edge => true}
thing and variation on that I found at other sites.
The RikiEngline package had the various ‘require’ and ‘start’
items you discuss already in it.


#11

I have experienced a lot of problems when deploying the combination of
FastCGI, Rails 1.1.2 in the vendors-dir and User- and Logine-engines,
especially those dreaded NoMethodErrors. You might want to take a look
on my
description of how to overcome various problems when deploying, since
you
seem to have similar problems:
http://casperfabricius.com/blog/2006/05/21/rails-on-dreamhost/


#12

Can you post the actual error messages, and also the version of the
Engines plugin you’re using? (You can find it in
/vendor/plugins/engines/init.rb). I’m determined to nail this issue
today.

FWIW, the :edge flag should no longer be relevant.

  • james

#13

You may want to confirm that script/plugin is actually downloading
from the proper SVN site (http://svn.rails-engines.org) and not the
very very old defunct one (https://opensvn.csie.org/rails_engines/) -
look at “script/plugin unsource” for more info.

  • james

#14

I deleted the engine plugine, user and login engines and reinstalled
them from the repository. So now I am sure I have the latest version. I
am still getting errors, though they are different now.

Here is the trace:

/Applications/Locomotive2/Bundles/rails112.locobundle/i386/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require__': no such file to load -- authenticated_user (MissingSourceFile) from /Applications/Locomotive2/Bundles/rails112.locobundle/i386/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from
/Applications/Locomotive2/Bundles/rails112.locobundle/i386/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
require' from /Users/nathan/Documents/epanel-migrate-to-112/config/../vendor/plugins/login_engine/init_engine.rb:6:instart_engine’
from
/Users/nathan/Documents/epanel-migrate-to-112/config/…/vendor/plugins/engines/lib/engines.rb:183:in
start_engine' from /Users/nathan/Documents/epanel-migrate-to-112/config/../vendor/plugins/engines/lib/engines.rb:132:instart’
from
/Users/nathan/Documents/epanel-migrate-to-112/config/…/vendor/plugins/engines/lib/engines.rb:131:in
`start’


#15

Hi James,

Yes I updated the engines by running:

ruby script/plugin update

which output

Updating plugin: ar_fixtures
Updating plugin: engines
Updating plugin: javascript_generator_templates
Updating plugin: login_engine
Updating plugin: user_engine

perhaps it only pretended to update them, I will try and update them
manually and see if that helps.

Regards
Nathan

James A. wrote:

Are you all running with the latest version of the Engines plugin?
Some of those line numbers indicate otherwise…

  • james

#16

James A. wrote:

Are you all running with the latest version of the Engines plugin?
Some of those line numbers indicate otherwise…

  • james

Hmmm. I don’t how I ended up with something other than the latest
version, but I didn’t have it. Updating it made the add_path problem go
away.

Thanks!


#17

Nathan Donaldson wrote:

I deleted the engine plugine, user and login engines and reinstalled
them from the repository. So now I am sure I have the latest version. I
am still getting errors, though they are different now.

Here is the trace:
/Applications/Locomotive2/Bundles/rails112.locobundle/i386/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require__': no such file to load -- authenticated_user (MissingSourceFile) from /Applications/Locomotive2/Bundles/rails112.locobundle/i386/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from

I get the exact same after upgrading Ubuntu to Dapper (6.0). In that
process I also gor Ruby 1.8.4 and Rails 1.1.

Anyone here that has login_engine running under Rails 1.1?


#18

FWIW, I couldn’t get anything much working following the instructions I
read in this list (“upgrade to the lastest version of engines,
etc…”). Instead, things are goog if I use the following
externals/revisions:

engines http://svn.rails-engines.org/engines/tags/rel_1.1.1/
login_engine http://svn.rails-engines.org/login_engine/tags/rel_1.0.1/
user_engine http://svn.rails-engines.org/user_engine/tags/rel_1.0.1/

rather than the “lastest” releases.

Perhaps I’m missing something?

-Jonathan

Jonas E wrote:

I get the exact same after upgrading Ubuntu to Dapper (6.0). In that
process I also gor Ruby 1.8.4 and Rails 1.1.

Anyone here that has login_engine running under Rails 1.1?


#19

James A. wrote:

Can you post the actual error messages, and also the version of the
Engines plugin you’re using? (You can find it in
/vendor/plugins/engines/init.rb). I’m determined to nail this issue
today.

FWIW, the :edge flag should no longer be relevant.

  • james

This is from the vanilla RikiEngine_0_3_2.tgz I downloaded and unpacked.

[anton@BigBoy RikiEngine_0_3_2]$ more vendor/plugins/engines/init.rb
#–

Copyright © 2005 James A.

require ‘engines’

module ::Engines::Version
Major = 1 # change implies compatibility breaking with previous
versions
Minor = 0 # change implies backwards-compatible change to API
Release = 6 # incremented with bug-fixes, updates, etc.
end

#…

The basic run is:

$ ruby script/server
=> Booting WEBrick…
./script/…/config/…/vendor/plugins/engines/lib/engines.rb:163:in
start_engine': undefined methodadd_path’ for Controllers:Module
(NoMethodError)
from
./script/…/config/…/vendor/plugins/engines/lib/engines.rb:122:in
start' from ./script/../config/../vendor/plugins/engines/lib/engines.rb:121:ineach’
from
./script/…/config/…/vendor/plugins/engines/lib/engines.rb:121:in
start' from ./script/../config/../config/environment.rb:70 from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire__’
from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require' from /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:inrequire’
from
/usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/commands/servers/webrick.rb:52
from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require__' from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
require' from /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/commands/server.rb:30 from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire__’
from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
require' from /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:inrequire’
from script/server:3

If I turn on debugging I get the following, much of which alarms me.

$ ruby -d script/server
Exception LoadError' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file to load -- initializer /usr/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/validations.rb:334: warning:*’ interpreted as argument prefix
/usr/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/validations.rb:363:
warning: *' interpreted as argument prefix /usr/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/migration.rb:224: warning: instance variable @ignore_new_methods not initialized /usr/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/migration.rb:224: warning: instance variable @ignore_new_methods not initialized /usr/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/connection_adapters/abstract/connection_specification.rb:41: warning: method redefined; discarding old allow_concurrency= /usr/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/connection_adapters/sqlserver_adapter.rb:456: warning: method redefined; discarding old remove_column ExceptionMissingSourceFile’ at
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file
to
load – db2/db2cli
Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file to load -- db2/db2cli ExceptionMissingSourceFile’ at
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150

  • No such file to load – db2/db2cli
    /usr/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/connection_adapters/oracle_adapter.rb:119:
    warning: (…) interpreted as grouped expression
    Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file to load -- oci8 ExceptionMissingSourceFile’ at
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file
    to
    load – oci8
    Exception `MissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • No such file to load – oci8
    Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file to load -- oci8 ExceptionMissingSourceFile’ at
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file
    to
    load – oci8
    Exception `MissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • No such file to load – oci8
    Exception `MissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/core_ext/kernel/requires.rb:19
  • No such file to load – oci8
    Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file to load -- sybsql ExceptionMissingSourceFile’ at
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file
    to
    load – sybsql
    Exception `MissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • No such file to load – sybsql
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/request.rb:169:
    warning: method redefined; discarding old relative_url_root
    Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file to load -- Win32API ExceptionMissingSourceFile’ at
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file
    to
    load – Win32API
    Exception `MissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • No such file to load – Win32API
    /usr/lib/ruby/1.8/cgi/session/pstore.rb:17: warning: method redefined;
    discarding old []=
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/cgi_ext/raw_post_data_fix.rb:57:
    warning: ambiguous first argument; put parentheses or even spaces
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/cgi_ext/raw_post_data_fix.rb:8:
    warning: method redefined; discarding old initialize_query
    Exception `DRb::DRbServerNotFound’ at /usr/lib/ruby/1.8/drb/drb.rb:1572

DRb::DRbServerNotFound
Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file to load -- memcache ExceptionMissingSourceFile’ at
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file
to
load – memcache
Exception `MissingSourceFile’ at
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150

  • No such file to load – memcache
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/session/active_record_store.rb:129:
    warning: private attribute?
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/session/active_record_store.rb:179:
    warning: method redefined; discarding old connection
    Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file to load -- redcloth ExceptionMissingSourceFile’ at
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file
    to
    load – bluecloth
    Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file to load -- html/tokenizer ExceptionGem::LoadError’ at
    /usr/lib/ruby/site_ruby/1.8/rubygems.rb:204 -
    RubyGem version error: facets(1.3.3 not = 1.0.3)

Exception `Gem::LoadError’ at
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150

  • RubyGem version error: facets(1.3.3 not = 1.0.3)

/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_view/helpers/prototype_helper.rb:640:
warning: ambiguous first argument; put parentheses or even spaces
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_view/helpers/prototype_helper.rb:873:
warning: *' interpreted as argument prefix /usr/lib/ruby/gems/1.8/gems/actionmailer-1.2.1/lib/action_mailer/vendor/tmail/facade.rb:486: warning: method redefined; discarding old create_reply ExceptionMissingSourceFile’ at
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file
to
load – tmail/base64.so
Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file to load -- tmail/base64.so ExceptionMissingSourceFile’ at
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150

  • No such file to load – tmail/base64.so
    Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file to load -- tmail/scanner_c.so ExceptionMissingSourceFile’ at
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file
    to
    load – tmail/scanner_c.so
    Exception `MissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • No such file to load – tmail/scanner_c.so
    Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file to load -- xmlscan/scanner ExceptionMissingSourceFile’ at
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file
    to
    load – xmlscan/scanner
    Exception `MissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • No such file to load – xmlscan/scanner
    Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file to load -- xmlscan/scanner ExceptionMissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • No such file to load – xmlscan/scanner
    Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file to load -- xml/parser ExceptionMissingSourceFile’ at
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file
    to
    load – xml/parser
    Exception `MissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • No such file to load – xml/parser
    Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file to load -- xml/parser ExceptionMissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • No such file to load – xml/parser
    Set XSD::XMLParser::REXMLParser as XML processor.
    Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file to load -- http-access2 ExceptionMissingSourceFile’ at
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file
    to
    load – http-access2
    Exception `MissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • No such file to load – http-access2
    Loading http-access2 failed. Net/http is used.
    /usr/lib/ruby/1.8/net/https.rb:121: warning: method redefined;
    discarding
    old edit_path
    /usr/lib/ruby/1.8/net/https.rb:130: warning: redefine socket_type
    /usr/lib/ruby/1.8/net/https.rb:157: warning: method redefined;
    discarding
    old on_connect
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:581: warning:
    method redefined; discarding old []=
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:590: warning:
    method redefined; discarding old []
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:595: warning:
    method redefined; discarding old keys
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:600: warning:
    method redefined; discarding old find_pair
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:607: warning:
    method redefined; discarding old []=
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:611: warning:
    method redefined; discarding old []
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:615: warning:
    method redefined; discarding old method_missing
    Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file to load -- fcgi ExceptionMissingSourceFile’ at
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file
    to
    load – fcgi
    Exception `MissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • No such file to load – fcgi
    Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file to load -- fcgi ExceptionMissingSourceFile’ at
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file
    to
    load – fcgi
    Exception `MissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • No such file to load – fcgi
    Exception `MissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/core_ext/kernel/requires.rb:19
  • No such file to load – fcgi
    => Booting WEBrick…
    Exception Errno::EEXIST' at /usr/lib/ruby/1.8/fileutils.rb:212 - File exists - tmp/sessions ExceptionErrno::EEXIST’ at /usr/lib/ruby/1.8/fileutils.rb:212 - File
    exists - tmp/cache
    Exception Errno::EEXIST' at /usr/lib/ruby/1.8/fileutils.rb:212 - File exists - tmp/sockets ExceptionMissingSourceFile’ at
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21 - No such file
    to
    load – simplecc
    Exception MissingSourceFile' at /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29 - No such file to load -- simplecc ExceptionMissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • No such file to load – simplecc
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/initializer.rb:483: warning:
    instance variable @after_initialize_block not initialized
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_user.rb:8:
    warning: redefine included
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_user.rb:39:
    warning: method redefined; discarding old authenticate
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_user.rb:45:
    warning: method redefined; discarding old authenticate_by_token
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_user.rb:59:
    warning: redefine hashed
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_user.rb:68:
    warning: redefine salted_password
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_user.rb:77:
    warning: method redefined; discarding old initialize
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_user.rb:82:
    warning: method redefined; discarding old token_expired?
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_user.rb:86:
    warning: method redefined; discarding old update_expiry
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_user.rb:93:
    warning: method redefined; discarding old generate_security_token
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_user.rb:102:
    warning: method redefined; discarding old set_delete_after
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_user.rb:112:
    warning: method redefined; discarding old change_password
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_user.rb:120:
    warning: method redefined; discarding old validate_password?
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_user.rb:125:
    warning: method redefined; discarding old crypt_password
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_user.rb:132:
    warning: method redefined; discarding old new_security_token
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_user.rb:139:
    warning: method redefined; discarding old token_lifetime
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_system.rb:14:
    warning: method redefined; discarding old authorize?
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_system.rb:29:
    warning: method redefined; discarding old protect?
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_system.rb:42:
    warning: method redefined; discarding old login_required
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_system.rb:65:
    warning: method redefined; discarding old access_denied
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_system.rb:71:
    warning: method redefined; discarding old store_location
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_system.rb:76:
    warning: method redefined; discarding old redirect_to_stored_or_default
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_system.rb:86:
    warning: method redefined; discarding old redirect_back_or_default
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_system.rb:94:
    warning: method redefined; discarding old user?
    ./script/…/config/…/vendor/plugins/login_engine/lib/login_engine/authenticated_system.rb:111:
    warning: method redefined; discarding old current_user
    Exception `MissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:140
  • No such file to load – controllers.rb
    Exception `MissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:143
  • No such file to load – controllers.rb
    Exception `MissingSourceFile’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:32
  • No such file to load – controllers.rb
    Exception NoMethodError' at ./script/../config/../vendor/plugins/engines/lib/engines.rb:163 - undefined methodadd_path’ for Controllers:Module
    Exception `NoMethodError’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • undefined method add_path' for Controllers:Module ExceptionNoMethodError’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • undefined method add_path' for Controllers:Module ExceptionNoMethodError’ at
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:150
  • undefined method add_path' for Controllers:Module ./script/../config/../vendor/plugins/engines/lib/engines.rb:163:instart_engine’: undefined method add_path' for Controllers:Module (NoMethodError) from ./script/../config/../vendor/plugins/engines/lib/engines.rb:122:instart’
    from
    ./script/…/config/…/vendor/plugins/engines/lib/engines.rb:121:in
    each' from ./script/../config/../vendor/plugins/engines/lib/engines.rb:121:instart’
    from ./script/…/config/…/config/environment.rb:70
    from
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
    require__' from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
    from
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
    require' from /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/commands/servers/webrick.rb:52 from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire__’
    from
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
    require' from /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:inrequire’
    from
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/commands/server.rb:30
    from
    /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
    require__' from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
    from
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
    `require’
    from script/server:3

n I downloaded the demo of RikiEngine_0_3_2.


#20

There was a minor issue with the latest version of the engines plugin
and the login engine. I’ve just updated the login engine, so the
latest versions of everything should now be compatible.

  • james