Upgrading radiant .5 to .6

How do I upgrade from radiant .5.2 to .6 ?

I am using Site5 hosting.

Any tutorials I can follow?

Keith

I get to step 2 and receive the following errors?

-bash-3.00$ gem update radiant
Updating installed gems…
ERROR: While executing gem … (NoMethodError)
undefined method `refresh’ for #Hash:0xb7d16b7c

keith wrote:

How do I upgrade from radiant .5.2 to .6 ?

I am using Site5 hosting.

Any tutorials I can follow?

I just created one:

http://dev.radiantcms.org/radiant/wiki/HowToUpgrade05xTo06


John L.
http://wiseheartdesign.com

On 5/4/07, John W. Long [email protected] wrote:

http://dev.radiantcms.org/radiant/wiki/HowToUpgrade05xTo06

I followed it and it worked to an extend. The site is up and running
but as soon as I try to
go to the admin part, it says:

Any idea?

Processing PageController#index (for 192.93.23.254 at 2007-05-07
12:10:56) [GET]
Session ID: 5428812cae82c78eaaed9c34fcff3ac8
Parameters: {“action”=>“index”, “controller”=>“admin/page”}
Rendering within layouts/application
Rendering admin/page/index

ActionView::TemplateError (The single-table inheritance mechanism
failed to locate the subclass: ‘Archive’. This error is raised because
the column ‘class_name’ is reserved for storing the class in case of
inheritance. Please rename this column if you didn’t intend it to be
used for storing the inheritance class or overwrite
Page.inheritance_column to use another column for that information.)
on line #44 of admin/page/_node.rhtml:
41: <% level = level + 1 -%>
42: <%
43: if expanded
44: page.children.each do |child|
45: -%>
46: <%= render_node child, :level => level, :simple => simple -%>
47: <%

On Sat, 05 May 2007 15:41:03 +0100, keith wrote:

I get to step 2 and receive the following errors?

-bash-3.00$ gem update radiant
Updating installed gems…
ERROR: While executing gem … (NoMethodError)
undefined method `refresh’ for #Hash:0xb7d16b7c

This looks like rubygems cache poisining. Did you recently also upgrade
rubygems? Here are some instructions from the Gentoo bugs database:

Going from rubygems-0.9.0-r2 to 0.9.1, the gem command gives me the
following
error:

raven ~ # gem install hpricot
ERROR: While executing gem … (NoMethodError)
undefined method `refresh’ for #Hash:0xb7c4e9bc

So far the only solution I’ve seen has been to manually delete
/usr/lib/ruby/gems/1.8/source_cache, and the one in ~/.gems/ if it
exists. I didn’t, as root, have a ~/.gems .

Ollivier R. wrote:

On 5/7/07, Ollivier R. [email protected] wrote:

On 5/4/07, John W. Long [email protected] wrote:

http://dev.radiantcms.org/radiant/wiki/HowToUpgrade05xTo06
I followed it and it worked to an extend. The site is up and running
but as soon as I try to
go to the admin part, it says:

More details: I’m using mongrel 1.0.1 with PostgreSQL 8.2.3 on FreeBSD
6.1-STABLE.

Mmm. That’s weird. Something failed in the upgrade process. Try
executing the following statement manually on the appropriate database:

update pages set class_name=“ArchivePage” where class_name=“Archive”;


John L.
http://wiseheartdesign.com

On 5/7/07, Ollivier R. [email protected] wrote:

On 5/4/07, John W. Long [email protected] wrote:

http://dev.radiantcms.org/radiant/wiki/HowToUpgrade05xTo06

I followed it and it worked to an extend. The site is up and running
but as soon as I try to
go to the admin part, it says:

More details: I’m using mongrel 1.0.1 with PostgreSQL 8.2.3 on FreeBSD
6.1-STABLE.


Ollivier R. -

On 5/7/07, John W. Long [email protected] wrote:

Mmm. That’s weird. Something failed in the upgrade process. Try
executing the following statement manually on the appropriate database:

update pages set class_name=“ArchivePage” where class_name=“Archive”;

Worked fine, it is back in business, thanks!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs