Upgrading project to Rails 2. New generated functional tests fail

When running the command

‘./script/generate scaffold SkillCategory name:text’

in a new Rails project, I get nicely generated code that passes all
its tests

When running the same code in my updated project the same code is
generated but four of the functional tests fail. The project has been
upgraded by using ‘rake rails:update’

The error messages are

test_should_destroy_skill_category(SkillCategoriesControllerTest):
NoMethodError: undefined method skill_categories' for #<SkillCategoriesControllerTest:0x19c7628> /Library/Ruby/Gems/1.8/gems/actionpack-2.0.2/lib/action_controller/ test_process.rb:464:inmethod_missing’
./test/functional/skill_categories_controller_test.rb:40:in
test_should_destroy_skill_category' /Library/Ruby/Gems/1.8/gems/activesupport-2.0.2/lib/active_support/ core_ext/test/unit/assertions.rb:39:inassert_difference’

Any ideas why this might be happening

Many thanks

Andrew

Problem solved, though not sure exactly how. Migrating more carefully
following guidelines from
http://www.sitepoint.com/blogs/2008/01/25/upgrading-to-rails-20-a-recipe/
seem to have solved it. Other possible cause was newby use of Git and
mixing of old and new branches.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs