Upgrading plugins methodology


#1

Hi, I’ve been cruising along trying to upgrade a rails 2.0.2 app to
2.2.2, but first made a pit stop at 2.1.2 based on some posts that I
read.

Are there any tutorials, guides etc… on how to keep the plugins
compatible with the latest version of Rails that I’m on? How would I
know what version of say attachment_fu was most compatible with 2.1.2?
If I grab the latest version of the plugin it might work for 2.2.2 but
not 2.1.2 etc…