Upgrade problem 0.5.2 to 0.6.1

I’m trying to upgrade from 0.5.2 (checked out version) to 0.6.1 (gem
version) and the migration runs fine until I try to hit it in a
browser after restarting and get the error

undefined local variable or method `behavior_id’

The full error is at the end of this message.
I’m on Windows and SQL Server running through mongrel

This refers to an older thread I started when I was testing the
upgrade process to 0.6rc2
http://lists.radiantcms.org/pipermail/radiant/2007-March/003904.html

Anyone have any ideas for me?
Thanks!

-Jim

Jim G. wrote:

undefined local variable or method `behavior_id’

The full error is at the end of this message.
I’m on Windows and SQL Server running through mongrel

Anyone have any ideas for me?

Stupid question, but I assume you restarted mongrel?


John L.
http://wiseheartdesign.com

On Jun 22, 2007, at 8:47 PM, John W. Long wrote:

Jim G. wrote:

undefined local variable or method `behavior_id’

The full error is at the end of this message.
I’m on Windows and SQL Server running through mongrel

Anyone have any ideas for me?

Stupid question, but I assume you restarted mongrel?

Not at all. Yes the mongrel service was restarted
I’m going to give it another go this week, but I tried it on a Friday
after a long week so I thought I’d ping the group to see if I was
just overlooking something.
Although, now, I guess I’ll attempt 0.6.2

Jim G. wrote:

I’m going to give it another go this week, but I tried it on a Friday
after a long week so I thought I’d ping the group to see if I was
just overlooking something.
Although, now, I guess I’ll attempt 0.6.2

Were you aware of this page:

http://wiki.radiantcms.org/How_to_Upgrade_05x_to_06


John L.
http://wiseheartdesign.com

Previously, I had written to the list and John was helping me figure
out problems with my upgrade.
I’m happy to say that I got things working (I think it had to do with
me forgetting to rake or run the proper environment)

Unfortunately, in my upgrade to 0.6.2 I though everything was fine.
But I just got this message from someone trying to edit a page:

Help! When I go to save changes to any page in Radiant, I get this
error message:

NoMethodError in Admin/pageController#edit

undefined method `+' for nil:NilClass

RAILS_ROOT: C:/Apps/Prod_Radiant/config/..

This seems to only occur on pre-existing pages.
I created a new test page and saved changes and had no problem. Then,
I edited a pre-existing page and had the same error as above.

Everything has been restarted (the entire server) and I’m on Windows/
Mongrel/SQL Server
John, is this thread still on your radar? Or anyone else have an idea
of what is going on?

I appreciate any help.

On Jun 24, 2007, at 4:50 PM, John W. Long wrote:

Jim G. wrote:

I’m going to give it another go this week, but I tried it on a Friday
after a long week so I thought I’d ping the group to see if I was
just overlooking something.
Although, now, I guess I’ll attempt 0.6.2

Were you aware of this page:

http://wiki.radiantcms.org/How_to_Upgrade_05x_to_06

Yup. I was following that as I worked on the upgrade on the remote
server.
Everything seemed to go fine. No errors during the upgrade and
migration… just when I go to view it.

On Jun 29, 2007, at 10:40 AM, Jim G. wrote:

RAILS_ROOT: C:/Apps/Prod_Radiant/config/..

This seems to only occur on pre-existing pages.
I created a new test page and saved changes and had no problem. Then,
I edited a pre-existing page and had the same error as above.

Sean helped me solve this problem.
The lock_version on existing pages was set to NULL in the database.
Sean suggested

UPDATE pages SET lock_version = 0 WHERE lock_version IS NULL

That solved it.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs