Updating installed Rails 1.0 to 1.1.2 without gem


#1

Hello,

on my Company-Computer ive Rails 1.0 installed. Now i want to update to Rails 1.1.2, but theres no chance to do this with gem because of a new
Firewall.

Is there any way to update to Rails 1.1.2 manually?

Thank you

Thorsten


#2

Yep. You download each gem pacakge from rubyforge, and install it. Start
by
downloading rails1.1.2.gem, type in gem install rails
–include-dependencies, check the error message (“rails requires
activeXXX”), download the dependencie activeXXX, install, …


#3

Hi Nicolas,

i did it as you wrote and after installation of each gem i executed
rails -v. Every time Rails told me which package was missing. After
installing each gem Rails -v printed Rails 1.1.2

I think it works.

Thank you!

Thorsten

Nicolas B. wrote:

Yep. You download each gem pacakge from rubyforge, and install it. Start
by
downloading rails1.1.2.gem, type in gem install rails
–include-dependencies, check the error message (“rails requires
activeXXX”), download the dependencie activeXXX, install, …