Updated lighttpd to 1.4.9 - error running dispatch.fcgi


#1

Hi all,

I just updated lighttpd from 1.4.8 to 1.4.9 and it now refuses to
start with the following error:

2006-01-24 23:12:24: (mod_fastcgi.c.989) execve failed for: public/
dispatch.fcgi No such file or directory

2006-01-24 23:12:24: (mod_fastcgi.c.1015) the fastcgi-backend public/
dispatch.fcgi failed to start:

2006-01-24 23:12:24: (mod_fastcgi.c.1019) child exited with status 2
public/dispatch.fcgi

The ruby interpreter is at /usr/local/bin/ruby and this is the
shebang-line in dispatch.fcgi.

All was working an hour ago with lighttpd 1.4.8. No other changes
have been made to the system or any other software.

Any ideas as to why this is happening?

OSX 10.4.4, ruby 1.8.4, lighttpd 1.4.9 (from darwinports), rails 1.0

Many thanks in advance,
– Nicky


#2

On 1/25/06, Nickolay K. removed_email_address@domain.invalid wrote:

I just updated lighttpd from 1.4.8 to 1.4.9 and it now refuses to
start with the following error:

2006-01-24 23:12:24: (mod_fastcgi.c.989) execve failed for: public/
dispatch.fcgi No such file or directory

What happends if you start the dispatch.fcgi directly from the command
prompt? Like:

…> /path/to/public/dispatch.fcgi


#3

On 25 Jan 2006, at 08:16, Stoyan Z. wrote:

What happends if you start the dispatch.fcgi directly from the command
prompt? Like:

…> /path/to/public/dispatch.fcgi

The script runs for a second and spits out:

Status: 500 Internal Server Error

Nicky


#4

I can confirm the issue. I just downgraded to lighttpd 1.4.8 and the
same setup is working wonderfully. Switching between versions 1.4.8
and 1.4.9 always displays the same behaviour–1.4.8 works as
advertised and 1.4.9 shows the aforementioned error messages.

Is anyone using lighttpd 1.4.9 successfully with FastCGI and an
unaltered dispatch.fcgi?

Nicky


#5

I’m running freebsd-5.4 and I’m having the exact same issue. I guess
downgrading to 1.4.8 is the solution. Been trying to figure this one out
for hours.

Thanks,
Fredrik


#6

Fredrik T. wrote:

I’m running freebsd-5.4 and I’m having the exact same issue. I guess
downgrading to 1.4.8 is the solution. Been trying to figure this one out
for hours.

Thanks,
Fredrik

I just downgraded to 1.4.8 and everything is good again. Dunno what
causes 1.4.9 to bomb.
Someone posted in the lighty forum about similar issues with php and
lighty-1.4.9, but no answer to what is causing it. The current bug list
did not seem to have anything useful in it either.

Fredrik


#7

I had this problem on Debian with 1.4.9 as well. I ended up downgrading
lighty.

Cody

On 1/25/06, Fredrik T. removed_email_address@domain.invalid wrote:

Someone posted in the lighty forum about similar issues with php and
http://lists.rubyonrails.org/mailman/listinfo/rails


http://www.codyfauser.com


#8

On 1/25/06, Nickolay K. removed_email_address@domain.invalid wrote:

Hi all,

I just updated lighttpd from 1.4.8 to 1.4.9 and it now refuses to
start with the following error:

2006-01-24 23:12:24: (mod_fastcgi.c.989) execve failed for: public/
dispatch.fcgi No such file or directory

[ http://trac.lighttpd.net/trac/ticket/487 ] - seems the problem with
relative paths. In general 1.4.9 looks too buggy - see the previous
tickets (482,483 etc.). Maybe staying with 1.4.8 is good.


#9

fwiw I have lighty 1.4.9 running just fine on FreeBSD 6.0. Upgrade
went smooth, none of my apps broke or anything.

I do get the error you’re reporting on my OS X box though. Haven’t
tried using 1.4.8 instead, but I’ll check it out.

Pat


#10

Yes, but on Redhat Enterpise Linux 4. Rails 1.0, lighttpd 1.4.9 from
source, and ruby 1.8.2 from source. Anything in particular you’d like
me to test?


#11

Oh well I guess that explains why it’s working fine for me on FreeBSD.
Every reference to dispatch.fcgi includes the full path.

I just changed the config/dispatch.fcgi file on my dev machine and it
works fine as well. Problem seems to be solved then, I don’t see why
anyone should have too much trouble changing two lines.

Pat


#12

I had the same problem. Seems the solution is to provide full paths
everywhere in the config/lighttpd.conf.
-jeff

On 1/25/06, Pat M. removed_email_address@domain.invalid wrote:

same setup is working wonderfully. Switching between versions 1.4.8
http://lists.rubyonrails.org/mailman/listinfo/rails


Rails mailing list
removed_email_address@domain.invalid
http://lists.rubyonrails.org/mailman/listinfo/rails


Jeff B. / removed_email_address@domain.invalid
Phone: (203)432-9940 51 Prospect Rm. 011
High Performance Computing (HPC)
UNIX Systems Administrator, WorkStation Support (WSS)
Yale University Information Technology Services (ITS)


#13

Nickolay K. wrote:

Perhaps a change is in order, so that from now on the copying of
lighttpd.conf to config/ should be followed by an amendment of the
full paths to dispatch.fcgi.

Nicky

Wouldn’t this break some of the auto deployment options? The beauty of
the relative path is that you can move the site to a different file
system or directory without breaking things.

Of course if the lighttpd team implemented this change as a security
thing it’s probably not negotiable.

/Mark


#14

I just changed the config/dispatch.fcgi file on my dev machine and it
works fine as well. Problem seems to be solved then, I don’t see why
anyone should have too much trouble changing two lines.

I came to the same solution for running 1.4.9. This obviously affects
only the script/server type of invocation, as a global lighttpd.conf
file (with virtual hosts anyway) would list the full paths anyway.

Perhaps a change is in order, so that from now on the copying of
lighttpd.conf to config/ should be followed by an amendment of the
full paths to dispatch.fcgi.

Nicky


#15

Mark Aufflick <mark@…> writes:

FYI 1.4.10 exhibits the same behaviour, so I assume it’s for good.

I found a article somewhere you can use the “constant” CWD + “path” in
.10.

-andi


#16

FYI 1.4.10 exhibits the same behaviour, so I assume it’s for good.


#17

David Heinemeier H. wrote:

FYI 1.4.10 exhibits the same behaviour, so I assume it’s for good.

I found a article somewhere you can use the “constant” CWD + “path” in .10.

Edge Rails now includes a default lighttpd.conf using CWD.

David Heinemeier H.
http://www.loudthinking.com – Broadcasting Brain
http://www.basecamphq.com – Online project management
http://www.backpackit.com – Personal information manager
http://www.rubyonrails.com – Web-application framework

Just a note to some that still can’t get it running.
I had the same problem and have tried everything that you guys
suggested, nothing worked, tried 3 versions of lighty with no luck.
Finally just for the heck of it I ran dos2unix on my
public/dispatch.fcgi file and then changes permissions on it. After
that lighttpd came up just fine, paths weren’t the problem for me it was
the dos file format for some reason.
Mike


#18

FYI 1.4.10 exhibits the same behaviour, so I assume it’s for good.

I found a article somewhere you can use the “constant” CWD + “path” in .10.

Edge Rails now includes a default lighttpd.conf using CWD.

David Heinemeier H.
http://www.loudthinking.com – Broadcasting Brain
http://www.basecamphq.com – Online project management
http://www.backpackit.com – Personal information manager
http://www.rubyonrails.com – Web-application framework