Unsupported platform?

1.7.12 throws this when I issue the ‘gem install rails’ command:

ERROR: Loading command: install (LoadError)
Unsupported platform: powerpc-unknown
ERROR: While executing gem … (NoMethodError)
undefined method `invoke_with_build_args’ for nil:NilClass

version info:

jruby -v
jruby 1.7.12 (1.9.3p392) 2014-04-15 643e292 on IBM J9 VM
jvmap3260sr14-20130705_01 [OS/400-PowerPC]

Rails would install in the last release I used (1.7.4) so is this error
coming back from gem or from jruby? Is there a workaround or hack I can
use to get moving (I am presenting on this tomorrow…I hate to have to
go back to an “old” version…)


Pete H.
www.petesworkshop.com
GIAC Secure Software Programmer-Java

does
$ gem install rails --platform java
pick the right platform.

not sure which gem does pick the wrong platform. maybe
$ gem install rails --verbose
gives some more inside.

just my 2 cents since I have no access to an OS/400-PowerPC machine.

  • christian

Thanks Christian. No joy on using --platform java

running ‘gem install rails --verbose’ didn’t help. The error is
apparently the first error it encounters (AFAICS).

Pete

Unsupported platform: powerpc-unknown
looks like a rubygems problem, you can at least try an upgrade your
rubygems or even downgrade (not sure here).

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs