Unknown protocol class usrp-server-cs

Okay, I can’t seem to get past this one which is blocking my progress.

I understand that usrp-server-cs and usrp-tx … etc are all defined in
the
usrp_server.mbh file which gets translated to usrp_server_mbh.cc which
is built.

According to the inband Makefile.am, it should be included in the inband
library:

libinband_la_SOURCES =
$(BUILT_SOURCES) \ <----------- here
usrp_server.cc

checking the output of make, it is included in the library:
ar cru .libs/libinband.a .libs/usrp_server_mbh.o .libs/usrp_server.o

And I am linking my qa code to this library:
libinband_qa_la_LIBADD =
libinband.la
$(CPPUNIT_LIBS)
-lstdc++

However I still get this error:
uncaught exception of type std::runtime_error

  • mb_port: unknown protocol class ‘usrp-server-cs’

What am I missing here? Do I need to register the usrp_server class as
an
mblock class somehow? I tried REGISTER_MBLOCK_CLASS() to no avail.

Thanks!

  • George

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs