Unknown attenuation after analysis filterbank


#1

Hi Gnuradio folks,

i am analysing the spectrum from 1MHz to 2Mhz. I splitted this Spectrum
into 3 parts:
1MHz - 1,333MHz
1,333MHz - 1,666MHz
1,666MHz - 2MHz

Therefore i used the Analysis Filterbank. Because i am searching for si
function
in the time domain as a response of a peak in the frequency domain, i
want
to use a band pass filter in the Analysis Filterbank.
Do i have to use the band pass filter or can i sill use the low pass
filter.
The response should be another one by using the Low pass filter ?

But my main Problem is, that my signal goes down in the second and third
band.
I doesn’t know why.

Here is my Flow Graph:
Usrp Source --> Analysis Filterbank+Band pass filter --> Selector -->
fft sink graph

My band pass looks like this:
samp_rate=1e6
Intermediate Frequency of the usrp= 1MHz
firdes.complex_band_pass(1.0, samp_rate, samp_rate0, samp_rate1/3,
samp_rate*0.01)

Any hints how to correct this ?
Did i anything wrong ?

regards Markus


#2

On Fri, May 15, 2009 at 8:18 AM, feldmaus removed_email_address@domain.invalid
wrote:

to use a band pass filter in the Analysis Filterbank.
My band pass looks like this:
samp_rate=1e6
Intermediate Frequency of the usrp= 1MHz
firdes.complex_band_pass(1.0, samp_rate, samp_rate0, samp_rate1/3,
samp_rate*0.01)

Any hints how to correct this ?
Did i anything wrong ?

So you are looking at 1MHz of spectrum with a sample rate of 1Msps
complex centered at 1MHz coming in from the USRP? Or do you receive a
complex stream directly from the USRP at baseband?

The CIC filter has roll off which could be your culprit? Do you have
a spectral plot of your bands as well as the entire incoming spectrum?

Brian


#3

Brian P. schrieb:

So you are looking at 1MHz of spectrum with a sample rate of 1Msps
complex centered at 1MHz coming in from the USRP? Or do you receive a
complex stream directly from the USRP at baseband?
I am looking from 1MHz to 2MHz, therefore i set up the frequency
in the Usrp to 1MHz and the samp_rate to 1Msps(1MHz Signa Bandwidth).

The CIC filter has roll off which could be your culprit? Do you have
a spectral plot of your bands as well as the entire incoming spectrum?
i will watching this next monday.

thanks and regards markus