Unit tests, salted hash login


#1

Hello,

I am having some trouble running the unit tests for the salted has login
generator. I am a bit new to both ruby and rails so I am having a little
trouble deciphering the error message I get when running ‘rake
test_units’. Up till the point where I try to run the unit tests I have
followed the quick start guide for the salted hash login generator
(http://wiki.rubyonrails.com/rails/pages/SaltedLoginGeneratorQuickstart),
my version of rake is 0.7.0. This is my error message

[brasse@keso login-test]$ rake test_units
(in /home/brasse/RAILS/login-test)
psql:db/development_structure.sql:37: NOTICE: CREATE TABLE will create
implicit sequence “users_id_seq” for “serial” column “users.id”
psql:db/development_structure.sql:46: NOTICE: ALTER TABLE / ADD PRIMARY
KEY will create implicit index “users_pkey” for table “users”
/usr/bin/ruby -Ilib:test
“/usr/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake/rake_test_loader.rb”
“test/unit/localization_test.rb” “test/unit/user_test.rb”
/usr/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:200:in
`const_missing’: uninitialized constant Test (NameError)
from ./test/unit/…/test_helper.rb:5
from ./test/unit/localization_test.rb:3
from
/usr/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake/rake_test_loader.rb:5
from
/usr/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake/rake_test_loader.rb:5
rake aborted!
Command failed with status (1): [/usr/bin/ruby -Ilib:test
"/usr/lib/ruby/ge…]

(See full trace by running task with --trace)

If someone could provide me with some clues on how to get the unit tests
running it would be great. Am I missing some package that I need? Some
other newbie mistake? All help will be greatly appriciated!

Regrads,
Mattias


#2

I am having some trouble running the unit tests for the salted has login
generator. I am a bit new to both ruby and rails so I am having a little
trouble deciphering the error message I get when running ‘rake
test_units’. Up till the point where I try to run the unit tests I have
followed the quick start guide for the salted hash login generator
(http://wiki.rubyonrails.com/rails/pages/SaltedLoginGeneratorQuickstart),
my version of rake is 0.7.0. This is my error message

Did you import the schema into your database? Step 10 of the wiki.
What type of db are you running?


#3

Nithin R. wrote:

I am having some trouble running the unit tests for the salted has login
generator. I am a bit new to both ruby and rails so I am having a little
trouble deciphering the error message I get when running ‘rake
test_units’. Up till the point where I try to run the unit tests I have
followed the quick start guide for the salted hash login generator
(http://wiki.rubyonrails.com/rails/pages/SaltedLoginGeneratorQuickstart),
my version of rake is 0.7.0. This is my error message

Did you import the schema into your database? Step 10 of the wiki.
What type of db are you running?

Yes , I did and I am running postgresql. As far as I can see the unit
tests manages to create a users table in my test database that look
exectly like the one in my devel database.

Regards,
Mattias