Unit testing is not running

Hi,

when i test the file for “Unit testing”, i am getting the following
errror as below,

/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
gem_original_require': no such file to load -- rails_test_serving (MissingSourceFile) from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in
require' from /root/enable/test/unit/../test_helper.rb:5 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:ingem_original_require’
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
require' from /root/enable/test/unit/user_test.rb:1 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:ingem_original_require’
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
require' from /usr/local/netbeans-6.5.1/ruby2/nb_test_mediator.rb:93:inrequire_file’
from /usr/local/netbeans-6.5.1/ruby2/nb_test_mediator.rb:109:in
add_to_suites' from /usr/local/netbeans-6.5.1/ruby2/nb_test_mediator.rb:108:ineach’
from /usr/local/netbeans-6.5.1/ruby2/nb_test_mediator.rb:108:in
add_to_suites' from /usr/local/netbeans-6.5.1/ruby2/nb_test_mediator.rb:66:inparse_args’
from /usr/local/netbeans-6.5.1/ruby2/nb_test_mediator.rb:59:in
loop' from /usr/local/netbeans-6.5.1/ruby2/nb_test_mediator.rb:59:inparse_args’
from /usr/local/netbeans-6.5.1/ruby2/nb_test_mediator.rb:166:in
`run_mediator’
from /usr/local/netbeans-6.5.1/ruby2/nb_test_mediator.rb:279

Finished in 0.0 seconds.
0 tests, 0 failures, 0 errors

I think i have missed some gem. could you anybody how to solve the
issue?.

Thanks & Regards,
Periyasamy.R

Hiya,

I’ts this bit that tells you:

/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require’: no such file to load – rails_test_serving
(MissingSourceFile)

i.e. rails_test_serving

http://github.com/Roman2K/rails-test-serving

There are install instructions on the github page.

Kind Regards
Luke

Hi,

Thanks for your quick reply. I will try this and reply you soon:)

Regards,
Periyasamy.R

Hi,

As your instruction i installed the “rails_test_serving” and ran the
file again. The Previous issue is solved. thanks. but again i am getting
the another error as below,

TypeError: wrong argument type Class (expected Module)
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/helpers.rb:76:in
include' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/helpers.rb:76:inadd_template_helper’
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/helpers.rb:76:in
module_eval' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/helpers.rb:76:inadd_template_helper’
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/helpers.rb:118:in
helper' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/helpers.rb:115:ineach’
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/helpers.rb:115:in
helper' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_view/test_case.rb:104:ininclude_helper_modules!’
/usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_view/test_case.rb:59:in
send' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_view/test_case.rb:59:insetup_with_controller’
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/callbacks.rb:178:in
send' /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/callbacks.rb:178:inevaluate_method’
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/callbacks.rb:166:in
call' /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/callbacks.rb:90:inrun’
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/callbacks.rb:90:in
each' /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/callbacks.rb:90:insend’
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/callbacks.rb:90:in
run' /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/callbacks.rb:276:inrun_callbacks’
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/testing/setup_and_teardown.rb:60:in
run' /usr/local/lib/ruby/1.8/test/unit/testsuite.rb:34:inrun’
/usr/local/lib/ruby/1.8/test/unit/testsuite.rb:33:in each' /usr/local/lib/ruby/1.8/test/unit/testsuite.rb:33:inrun’
/usr/local/lib/ruby/1.8/test/unit/ui/testrunnermediator.rb:46:in
`run_suite’

Finished in 5.295 seconds.
44 tests, 0 failures, 7 errors

you have any idea plz?.

Regards,
Periyasamy.R

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs