"uninitialized constant Gem::Etc (NameError)" when starting server

I keep getting this when I try to start the server:

[Macintosh:rails/work/demo] jslicari% script/server
/Library/Ruby/Site/1.8/rubygems.rb:723:in set_paths': uninitialized constant Gem::Etc (NameError) from /Library/Ruby/Site/1.8/rubygems.rb:719:ineach’
from /Library/Ruby/Site/1.8/rubygems.rb:719:in set_paths' from /Library/Ruby/Site/1.8/rubygems.rb:526:inpath’
from /Library/Ruby/Site/1.8/rubygems/source_index.rb:66:in
installed_spec_directories' from /Library/Ruby/Site/1.8/rubygems/source_index.rb:56:infrom_installed_gems’
from /Library/Ruby/Site/1.8/rubygems.rb:736:in source_index' from /Library/Ruby/Site/1.8/rubygems.rb:140:inactivate’
from /Library/Ruby/Site/1.8/rubygems.rb:49:in gem' from ./script/../config/boot.rb:59:inload_rails_gem’
from ./script/…/config/boot.rb:53:in load_initializer' from ./script/../config/boot.rb:38:inrun’
from ./script/…/config/boot.rb:11:in boot!' from ./script/../config/boot.rb:109 from script/server:2:inrequire’
from script/server:2

I have made sure everything is up to date with “sudo gem update” and
“sudo gem update --system”

Here are the versions I have:

[Macintosh:rails/work/demo] jslicari% gem -v
1.3.1
[Macintosh:rails/work/demo] jslicari% ruby -v
ruby 1.8.1 (2003-12-25) [powerpc-darwin]
[Macintosh:rails/work/demo] jslicari% rails -v
Rails 2.2.2

Thanks

Your version of ruby may be too old. See
http://rubyforge.org/tracker/index.php?func=detail&aid=22313&group_id=126&atid=575

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs