Uninitialized constant Enum with Webrick & RMagick

Hi,

I try run a rails controller which uses RMagick for graphic generation.
However, each time I load the “myController.rhtml” I always get the same
error:
“uninitialized constant Enum”, if I run on the same code on commandline
by using “ruby -I /usr/…/…/RMagick/lib myController.rb”, the RMagick
works correctly, the image is generated, but when I try to run it in
Rails, it doesnt’ work, Is there any specific configuration I have to
put in the config.rb …or else for rails?

Thanks you very much

Sayoyo

sayoyo wrote:

Hi,

I try run a rails controller which uses RMagick for graphic generation.
However, each time I load the “myController.rhtml” I always get the same
error:
“uninitialized constant Enum”, if I run on the same code on commandline
by using “ruby -I /usr/…/…/RMagick/lib myController.rb”, the RMagick
works correctly, the image is generated, but when I try to run it in
Rails, it doesnt’ work, Is there any specific configuration I have to
put in the config.rb …or else for rails?

Thanks you very much

Sayoyo

Usually this is caused by not having the web server configured to make
the LD_LIBRARY_PATH environment variable available. See
http://rubyforge.org/forum/forum.php?thread_id=7526&forum_id=33.

HI,

I have already read the information, (Thanks you!!!) however, our server
is not lighttpd…it is still webrick, and I didn’t find any information
about its configuration that I can “set” the path, my $LD_LIBRARY_PATH
is already set, but I wonder a $RUBYLIBS will it be the same???

Thanks you very much

Sayoyo

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs