Unexpected "unexpected kEND, expecting $"

I know about this error. It appears when you put an END in a wrong
place or forget to close a parentesis etc … But I have only a module
helper with two lines in a file named “noticias_helper.rb”

Module NoticiasHelper
end

I have checked with hexdump to see if there are an strange character
and it is not

hexdump -c app/helpers/noticias_helper.rb
0000000 M o d u l e N o t i c i a s
H
0000010 e l p e r \n e n d \n
hexdump app/helpers/noticias_helper.rb
0000000 6f4d 7564 656c 4e20 746f 6369 6169 4873
0000010 6c65 6570 0a72 6e65 0a64

And this is my error message in development.log

SyntaxError (/web/hika/config/…/app/helpers/noticias_helper.rb:2:
parse error, unexpected kEND, expecting $): /vendor/rails/
activerecord/lib/…/…/activesupport/lib/active_support/
dependencies.rb:140:in load' /vendor/rails/activerecord/lib/../../activesupport/lib/ active_support/dependencies.rb:140:inload’
/vendor/rails/activerecord/lib/…/…/activesupport/lib/
active_support/dependencies.rb:56:in require_or_load' /vendor/rails/activerecord/lib/../../activesupport/lib/ active_support/dependencies.rb:30:independ_on’
/vendor/rails/activerecord/lib/…/…/activesupport/lib/
active_support/dependencies.rb:85:in require_dependency' /vendor/rails/actionpack/lib/action_controller/helpers.rb:114:indefault_helper_module!’
/vendor/rails/actionpack/lib/action_controller/helpers.rb:127:in
inherited_without_api' /vendor/rails/actionwebservice/lib/action_web_service/container/ action_controller_container.rb:86:ininherited_without_action_controller’
/vendor/rails/actionwebservice/lib/action_web_service/dispatcher/
action_controller_dispatcher.rb:34:in inherited' /app/controllers/noticias_controller.rb:2 /vendor/rails/activerecord/lib/../../activesupport/lib/ active_support/dependencies.rb:140:inload’
/vendor/rails/activerecord/lib/…/…/activesupport/lib/
active_support/dependencies.rb:56:in require_or_load' /vendor/rails/activerecord/lib/../../activesupport/lib/ active_support/dependencies.rb:30:independ_on’
/vendor/rails/activerecord/lib/…/…/activesupport/lib/
active_support/dependencies.rb:85:in require_dependency' /vendor/rails/activerecord/lib/../../activesupport/lib/ active_support/dependencies.rb:98:inconst_missing’
/vendor/rails/activerecord/lib/…/…/activesupport/lib/
active_support/dependencies.rb:131:in const_missing' generated/routing/recognition.rb:4:inrecognize_path’
/vendor/rails/actionpack/lib/action_controller/routing.rb:477:in
recognize!' /vendor/rails/railties/lib/dispatcher.rb:38:indispatch’
/usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/
rails.rb:78:in process' /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/ rails.rb:76:inprocess’
/usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb:
618:in process_client' /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb: 617:inprocess_client’
/usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb:
736:in run' /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb: 736:inrun’
/usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb:
720:in run' /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/ configurator.rb:271:inrun’
/usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/
configurator.rb:270:in run' /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/mongrel_rails: 127:inrun’
/usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/
command.rb:211:in `run’
/usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/mongrel_rails:
243
/usr/local/bin/mongrel_rails:18

I am using ferret (0.11.4) and act_as_ferret 0.4.0

In which part on the program I need to look in order to catch my bug?

Best Regards

try using “module” not “Module”

-mike

On 4/9/07, thooby [email protected] wrote:

SyntaxError (/web/hika/config/…/app/helpers/noticias_helper.rb:2:
active_support/dependencies.rb:85:in require_dependency' /vendor/rails/activerecord/lib/../../activesupport/lib/ active_support/dependencies.rb:131:inconst_missing’
/usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel.rb:
configurator.rb:270:in `run’
In which part on the program I need to look in order to catch my bug?

Best Regards


-mike

Thanks Mike, It works. What a stupid error!

juan

sometimes the most obvious are the hardest errors to find.

Your welcome.

On 4/9/07, thooby [email protected] wrote:

On 4/9/07, thooby [email protected] wrote:

end
0000010 6c65 6570 0a72 6e65 0a64
active_support/dependencies.rb:56:in require_or_load'inherited_without_action_controller’
active_support/dependencies.rb:85:in require_dependency' /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/ 720:inrun’
/usr/local/bin/mongrel_rails:18


-mike